How to remove WordPress comment system?

Community Forums Forums Design Tips and Tricks How to remove WordPress comment system?

This topic is: not resolved

This topic contains 9 replies, has 3 voices, and was last updated by  maheshone 3 months, 1 week ago.

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #95024

    maheshone
    Participant
    Post count: 76

    Hi,

    I’ve recently migrated my blog’s (http://www.minterest.org/) comment system to Disqus and it’s working fine. But I’ve noticed that a glimpse of WordPress Comment System is shown just before Disqus.

    I asked their support team and they told me that…

    The wordpress comment system will display on your page before Disqus rendered, to change this behavior you would need to edit your WordPress theme to not show comments on the page.

    So how do I do that?


    http://www.minterest.org/
    #95101

    Pixel Frau
    Participant
    Post count: 83

    Have you tried disabling comments in the Genesis settings? Genesis > Theme Settings > Comments and Trackbacks.


    #95107

    maheshone
    Participant
    Post count: 76

    Yes, I just tried disabling comments and trackbacks… It disabled both wordpress comment system and disqus comment system. :(


    #100032

    davebonds
    Member
    Post count: 13

    Try adding this to your functions.php file to remove the genesis_get_comments_template action:

    remove_action( 'genesis_after_entry', 'genesis_get_comments_template' );

    #100055

    maheshone
    Participant
    Post count: 76

    Thanks for the response…

    I have tried some options like that before.. and tried the code that you provided me… but it’s removing the comment system as a whole… I mean it disabled WordPress comments and Disqus comments.

    Screenshot:



    #100059

    davebonds
    Member
    Post count: 13

    Looking at your site and all I’m seeing is Disqus. Not seeing what is in your screenshot or any remnants of the default WP comments.

    #100060

    maheshone
    Participant
    Post count: 76

    Hi,

    I added the code that you provided and it removed both disqus and wp comments.. so reversed those changes…

    You can check this:

    It’s a screenshot of the page http://www.minterest.org/how-to-recover-from-google-penalties/. As you can see.. the disqus comment also shows the same comments.. but here i can see a quick glance of wp comments for a few seconds before disqus starts loading…


    #100063

    davebonds
    Member
    Post count: 13

    It sounds like Disqus requires the default WP comments to be displayed in order to display Disqus, and as they mention, it will show default WP comments while the page loads then it will be replaced with Disqus.

    You can probably hide the default comments section with CSS to prevent it from showing in the browser while the page loads:

    .entry-comments {display: none;}

    #100065

    maheshone
    Participant
    Post count: 76

    Hi,

    I will try this as well.. and btw… I asked disqus team and they told me that.. removing wp-comments file from the home directory will solve the problem.. but it didn’t work for me….

    And they also suggested the code to reomove comments from the theme.. and again it didnt work…

    Also, I’m using Google PageSpeed Service CDN but they told me that their service is compatible with PSS… So absolutely clueless about this issue…

    Anyways, I will try your trick and update here tomorrow.


    #101136

    maheshone
    Participant
    Post count: 76

    Hi,

    Sorry for the delay… I tried that… and even that didn’t work… :(


Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.