How to turn off footer widgets everywhere but the homepage

Community Forums Forums General Discussion How to turn off footer widgets everywhere but the homepage

This topic is: resolved

This topic contains 6 replies, has 2 voices, and was last updated by  fieldmouse 10 months, 1 week ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #79585

    fieldmouse
    Member
    Post count: 21

    I am using the Education theme and need to be able to turn off the footer widgets everywhere but the homepage. Can this be done?

    #79605

    nutsandbolts
    Moderator
    Post count: 3173

    You can remove the footer widgets function from functions.php and add it to home.php before genesis(); at the bottom.


    Andrea Whitmer, Owner, Nuts and Bolts Media
    I provide dev and training services for web designers • Find me on Twitter and Google+

    #79608

    fieldmouse
    Member
    Post count: 21

    Okay, thanks, trying this!

    #79610

    fieldmouse
    Member
    Post count: 21

    Well, that got rid of footer widgets everywhere, including the homepage.

    #79612

    nutsandbolts
    Moderator
    Post count: 3173

    Hmmm, that’s interesting. I just did this on a site earlier today (though it was using a different child theme, but that shouldn’t matter).

    This tutorial from Brad Dalton may help, depending on how your homepage is set up: http://wpsites.net/web-design/remove-footer-specific-pages/


    Andrea Whitmer, Owner, Nuts and Bolts Media
    I provide dev and training services for web designers • Find me on Twitter and Google+

    #79614

    fieldmouse
    Member
    Post count: 21

    I am reading through that post and it looks awesome. Thanks a million, Andrea!

    #79617

    fieldmouse
    Member
    Post count: 21

    Found a snippet there that worked beautifully!
    Thanks for pointing me to such a great resource!

    I think the codes I have are rather idiosyncratic – a lot has been deleted I am finding, from the original theme files; that combined with my being a novice at all this is probably why the swap you mentioned didn’t work as it ought to have. Anyway, problem solved – and you are the best! :)

    • This reply was modified 10 months, 1 week ago by  fieldmouse.
    • This reply was modified 10 months, 1 week ago by  fieldmouse.
Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.