HTML5 Magazine Theme Issue with RSS Feed

Community Forums Forums General Discussion HTML5 Magazine Theme Issue with RSS Feed

This topic is: resolved

This topic contains 5 replies, has 3 voices, and was last updated by  valeryvie 11 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #81083

    valeryvie
    Participant
    Post count: 8

    Hi :-)

    I have a quirky issue going on…

    We have several sites using Studiopress, but only 1 on the new HTML5 template. We recently discovered that the RSS feed is not working on the site using the HTML5 Magazine theme… I disabled all of the plugins, and could not get it to work. But as soon as I disabled the template, the RSS worked again. RSS works on all of the other sites, which are not on HTML5 templates.

    We use skimlinks.com on both sites.

    RSS not working

    http://dailyvenusdiva.com

    RSS working

    http://bassmusicianmagazine.com

    The error message I get on dailyvenusdiva.com is:

    This feed does not validate.
    line 1, column 0: Undefined root element: script [help]
    <script type=”text/javascript” src=”http://s.skimresources.com/js/29186X8697 …
    line 2, column 1: XML parsing error: <unknown>:2:1: junk after document element [help]
    <div style=”display:none”>
    ^
    Source: http://dailyvenusdiva.com/feed/

    <script type=”text/javascript” src=”http://s.skimresources.com/js/29186X869761.skimlinks.js”></script>
    <div style=”display:none”>

    Any suggestions on how to fix this? Skimlinks works perfectly on bassmusicianmagazine.com with the non-HTML5 template.

    Thanks and thrive…

    Valery

    #81094

    nutsandbolts
    Keymaster
    Post count: 3187

    Check your functions.php and your home.php or front-page.php to be sure there are no blank lines at the end of the file. Sometimes that can cause RSS feeds not to validate. Also, if you’ve edited wp-config.php you might want to check that as well (though I’m guessing it’s one of the theme files).


    Andrea Whitmer, Owner, Nuts and Bolts Media
    I provide dev and training services for web designers • Find me on Twitter and Google+

    #81095

    nutsandbolts
    Keymaster
    Post count: 3187

    This will give you more info on the errors and what could be causing them: http://validator.w3.org/check?uri=http%3A%2F%2Fdailyvenusdiva.com%2Ffeed%2F&charset=%28detect+automatically%29&doctype=Inline&group=0


    Andrea Whitmer, Owner, Nuts and Bolts Media
    I provide dev and training services for web designers • Find me on Twitter and Google+

    #81525

    valeryvie
    Participant
    Post count: 8

    Thank you for the information!

    I used the validator, and 2 errors came up, but I don’t see where in the home.php or front-page-php to fix them… is there an easy way to find the errors in these files?

    the errors say:

    Error1
    Warning No DOCTYPE found! Checking XML syntax only.
    The DOCTYPE Declaration was not recognized or is missing. This probably means that the Formal Public Identifier contains a spelling error, or that the Declaration is not using correct syntax, or that your XML document is not using a DOCTYPE Declaration.
    Validation of the document has been skipped, and a simple check of the well-formedness of the XML syntax has been performed instead.
    Learn how to add a doctype to your document from our FAQ, or use the validator’s option to validate your XML document against a specific Document Type
    Info No Character encoding declared at document level

    Error2
    No character encoding information was found within the document, either in an HTML meta element or an XML declaration. It is often recommended to declare the character encoding in the document itself, especially if there is a chance that the document will be read from or saved to disk, CD, etc.
    See this tutorial on character encoding for techniques and explanations.

    And if the errors are in the home.php or front-page-php, would this be an error in the template, as I did not change anything in those files? Thanks for you help :-)

    Thrive…

    Valery ~

    #81570

    Summer
    Participant
    Post count: 1122

    Have you tried skimlinks on other HTML5 themes, both Genesis and standalone?

    I’d suggest trying the site using a different HTML5 theme as a test, and if skimlinks also fails there, then maybe that the problem isn’t the theme, but that skimlinks doesn’t quite work with yet?

    Or, maybe another plugin is messing you up… I just did a view source of your site, and I see <!DOCTYPE html> in there twice… once at the very top, and again in between your favicon loader and before your Google Analytics code… maybe that second one is causing the validation fail.


    #81968

    valeryvie
    Participant
    Post count: 8

    Thanks for the info! It is working now :-)

    I have had to disable the template and all of the plugins twice to get it to work… there must have been some strange glitch :-)

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.