I'm trying to make a custom loop work.

Community Forums Forums Design Tips and Tricks I'm trying to make a custom loop work.

This topic is: not resolved

This topic contains 1 reply, has 2 voices, and was last updated by  SoZo 1 year, 7 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #8881

    echoca
    Participant
    Post count: 1

    I can not get my custom loop to work right for a custom taxonomy page. this is the code I have in my taxonomy-event-location.php.
    remove_action('genesis_loop', 'genesis_do_loop');
    add_action('genesis_loop', 'do_my_event_locations_loop');
    function do_my_event_locations_loop() {
    global $query_args;
    global $paged;
    $term = get_query_var( 'term' );
    $args = array(
    'post_type' => 'sc_event',
    'tax_query' => array(
    'taxonomy' => 'event-locations',
    'field' => 'slug',
    'terms' => $term
    )
    );
    genesis_custom_loop( wp_parse_args( $query_args , $args ) );
    }

    It loads the right post type but I can not get the terms or paging to work. So clicking filed under … i just get the full list of terms and clicking page 2 gives a page not found.

    Thanks for reading and any help. Happy New Year!

    #17144

    SoZo
    Moderator
    Post count: 1573

    Please include a link to your site with all questions so that people can see what is going on.


    John “Nicolas Flamel” Wright | SoZo’s design| John Wright Photography

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.