Is There a Trick to Allowing Comments?

Community Forums Forums General Discussion Is There a Trick to Allowing Comments?

This topic is: resolved

Tagged: 

This topic contains 2 replies, has 2 voices, and was last updated by  idchowdhury@gmail.com 1 year, 8 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #13265

    idchowdhury@gmail.com
    Participant
    Post count: 5

    Probably there is something obvious I am not doing, but I can’t seem to enable “comments” to my posts.  I am using Genesis 1.9.x and the Corporate child theme.  I went to “discussion” and checked “allow anyone to comment” (along with the safeguard of requiring moderator approval).  When I go to my site, I cannot see a comment box on the Blog page, nor on the “testimonial” page. (The testimonial page is actually just a post with the “testimonial” as a category that I managed to get onto the menu — so I don’t know if that will create a complicating issue).

    Any insights by anyone would be appreciated!  The site is CaliforniaCollectionDefense.com

    Thank you!

    #13274

    Bill Murray
    Participant
    Post count: 575

    A few things to check:

    1) are comments allowed on the particular post/page? see your post/page edit screen. Comments can be turned off on an individual post/page basis. If some options are not appearing on the post/page edit screen, click the screen options in the upper right.

    2) for your defaults, see Genesis->Theme Settings. Changing these defaults won’t impact current posts/pages, only new ones.

    3) a plugin conflict? If all of your settings are correct, it could be a plugin conflict. You’d have to deactivate all plugins, reactivate them 1 x 1 and test after each reactivation. That would help you to find the troublesome plugin.

    Hope that helps.


    Web: https://wpperform.com or Twitter: @wpperform

    We do managed WordPress hosting.

    #13349

    idchowdhury@gmail.com
    Participant
    Post count: 5

    Thank you, Bill.  You hit the nail on the head: I created the posts prior to configuring the discussion settings to allow comments.  Thus, the pre-existing posts still did not allow comments.    As you further predicted, there was no “discussion” controls showing on the individual post settings, so I had to check-the “discussion” box on “screen settings” in order to show the relevant controls to turn-on comments for each post.  Thanks again!

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.