jQuery Slider in Genesis Child Theme

Community Forums Forums General Discussion jQuery Slider in Genesis Child Theme

This topic is: not resolved

Tagged: 

This topic contains 1 reply, has 2 voices, and was last updated by  Susan 6 months, 1 week ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #91716

    Hello. I am porting over a site from a .net cms into a genesis child theme. The element of their old site that they were most excited about was a fancy jQuery slider that used a sliding accordion, thumbnail navigation (quite a mouthful). I am using slider revolution for the actual slider, and I am trying to use the code from the previous site for the navigation. Unfortunately, the navigation does not want to work (see below for a screenshot). I have loaded the javascript and style sheet through wp_register and wp_enqueue, but there seems to still be an issue. Here is the code in my functions.php:

    add_action( ‘wp_enqueue_scripts’, ‘scp_enqueue_ch_script’);
    function scp_enqueue_ch_script() {
    wp_register_script(‘stage_set’, get_stylesheet_directory_uri() . ‘/js/stage.set.js’, array( ‘jquery’ ), ”, true );
    wp_register_script(‘stage’, get_stylesheet_directory_uri() . ‘/js/stage.js’, array( ‘jquery’ ), ”, true );
    wp_register_style(‘stage_css’, get_stylesheet_directory_uri() . ‘/stage.css’, ”, ”, ‘screen’);

    wp_enqueue_script( ‘stage_set’);
    wp_enqueue_script( ‘stage’);
    wp_enqueue_style( ‘stage_css’);
    }

    Here is a fiddle for what is supposed to happen (I pasted both stage_set.js and stage.js into the same javascript field) –

    Unfortunately, when I load the page with the appropriate code, here is a screenshot of what happens – The thumbnail navigation does not respond in any way.

    The site seems to be loading the javascript, but there appears to be an issue with the way it is reading the javascript. I would appreciate any help. I wish the client wasn’t so stuck on the particular navigation style, but they are insisting on using it. Please let me know if I can provide any further information.

    Thank you,
    walkingmiller

    #100433

    Susan
    Moderator
    Post count: 9254

    As you posted this a while ago, I hope you got your issue resolved. If not, please let me know, and I will take a look (or escalate if I cannot help).

    If it is resolved, please mark it resolved, so that the thread can be closed.

    Thanks!


    Susan @ Graphically Designing I offer theme customizations I tweet!
    I’ve taken up the challenge! – help me answer some of the unanswered posts

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.