Logo link in Executive Theme

Community Forums Forums General Discussion Logo link in Executive Theme

This topic is: not resolved

This topic contains 19 replies, has 5 voices, and was last updated by  Kalvik 1 year, 3 months ago.

Viewing 5 posts - 16 through 20 (of 20 total)
  • Author
    Posts
  • #49219

    John
    Participant
    Post count: 157

    Ted,

    Here’s a better way to do that: How to replace the StudioPress background header image with a real image logo

    John


    John Sundberg | blackhillswebworks.com
    A WordPress developer’s toolbox: Firebug | WordPress Codex | Google ;)

    #49283

    klipklopp
    Participant
    Post count: 30

    Hi John,

    Thanks for the link. I will this a try. One question… When Studiopress updates Genesis or the Executive theme, will this changing of the code be wiped out by the update – so I have to redo this any time I update?

    Thanks!

    Ted

    #49320

    John
    Participant
    Post count: 157

    Hi Ted,

    All you’re changing is the functions.php and style.css files in your child theme, which you’ve probably already edited anyway for other changes you’ve made to your site. If those two files are updated in a future child theme update then you’d have to merge any changes you’ve made along the way. Fortunately, that doesn’t happen very often with StudioPress themes.

    Updating Genesis doesn’t affect your child theme so you’d be okay there.

    I haven’t tried this yet with Genesis 2.0 but Marc, another commenter on that blog post, said he’s going to give it a try this weekend and see what happens.

    John


    John Sundberg | blackhillswebworks.com
    A WordPress developer’s toolbox: Firebug | WordPress Codex | Google ;)

    #49363

    Kalvik
    Participant
    Post count: 13

    Hi – I followed the instructions of Doak “The proper way to add a logo image in lieu of the Site Title & Description is here. ”

    But logo is floating higher (blank space below). I have checked the image of 350px X 90px matches .css

    background: url( ‘images/Elitelogoweb.png’ ) no-repeat;
    display: block;
    float: left;
    height: 90px;
    overflow: hidden;
    padding: 0;
    text-indent: -9999px;
    width: 350px;

    When changing width to 250px it’s back to a singe space but logo is cut short.

    #49368

    Kalvik
    Participant
    Post count: 13

    Ok – I got it – I had to adjust the width on the header.widget area
    #header .widget-area {
    float: right;
    width: 50%;
    }

    Whew.

Viewing 5 posts - 16 through 20 (of 20 total)

You must be logged in to reply to this topic.