Lost translation on search-button

Community Forums Forums General Discussion Lost translation on search-button

This topic is: resolved

This topic contains 10 replies, has 6 voices, and was last updated by  Pulppi 1 year, 7 months ago.

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #10392

    Pulppi
    Participant
    Post count: 2

    Hello

    I updated yesterday the genesis 1.9. After updating, I noticed that the text in search button was in english. It should be in finnish, since I have genesis translation plugin installed. Before genesis 1.9 update, translation in search button worked well. The search button was translated into my mother tangue.

    I also updated genesis translations into latest version, but it did not help.

    What should I do? My webpage is following:

    http://www.salkunrakentaja.com

     

    #10813

    rammen
    Participant
    Post count: 7

    I got the same problem after i updated to the latest version. Some text are back to english, but some are still in my native language. How do i translate the rest? http://www.finanssans.no

    #10988

    Pulppi
    Participant
    Post count: 2

    No, this has not been solved yet.

    #11114

    wpsmith
    Moderator
    Post count: 178

    Nothing was touched with this in Genesis 1.9. Everything from my standpoint is translatable. What plugins are you using? Can you please post what’s in your functions.php file?


    Travis Smith | Recommended StudioPress Developer & Contributor
    WP Smith | @wp_smith | GitHub

    Due to the forums, please paste code using Pastebin, JS Fiddle (for JavaScript) or GitHub.
    How to use Firebug for Designers by SixRevisions

    #11162

    Remkus de Vries
    Moderator
    Post count: 24

    Lots of strings were changed and have to therefor be translated again. Sometimes it’s just the difference of one character that requires a strings to be translated again. The translations over here http://translate.studiopress.com/projects/genesis-framework/genesis-19 are what feed my Genesis Translations plugin, so if you want to help out in translating the remaining strings that would be lovely :). You can register for the translation site here: http://translate.studiopress.com/home/.

    If you need to translate the button right now, there is a snippet of code that can help you with that: http://my.studiopress.com/snippets/search-form/#input-box


    More about me: ForSite Media | Remkus de Vries.

    Genesis Plugins: Genesis Translations | Genesis Toolbar+ | Genesis Prose Exporter
    Make the CSS editing part of your life easier for yourself – use Google Chrome and its Developers Tools.

    #11168

    David Decker
    Moderator
    Post count: 93

    What @Remkus said!

    The search placeholder string definitely changed from “Search this website %s” in 1.8.x to “Search this website” in 1.9.x!

    The search button string did not change as of my comparing — but if the language file for your language was not properly made then this still could lead to non-loaded/non-displayed translated strings.

    Also, like @wpsmith said, if you have modified such strings via functions.php — like suggested by the tutorials regarding “Search” on StudioPress here, then this will be used instead of language file string.

    To speed things up anyway, just jump in on the community translation portal mentioned above and @Remkus will add all these to the Genesis Translations plugin.

    –David Decker, community translation helper


    #11180

    Gary Jones
    Moderator
    Post count: 686

    Also, “Search this website” is not in the .pot file, as I suspect that esc_attr__() got missed from the list of marker functions in POEdit.


    Changes in Genesis 2.1 – the ultimate guide to every single change in Genesis Framework 2.1 and 2.1.1 (all 88 of them!) | @GaryJ

    #11188

    rammen
    Participant
    Post count: 7

    I just installed the translate plugin. Im using Norwegian language and there is some mistakes. Like “Saved underArticle” Without space between under and article. I also noticed that twitter pluing is translated but not the word “days”.  Great plugin anyway!

    #11210

    David Decker
    Moderator
    Post count: 93

    @GaryJ:

    That’s not true, maybe in the .pot file you has, but it’s in the actual PHP files!

    For 1.9.x:
    #@ genesis
    #: lib/structure/search.php:23
    msgid "Search this website"

    I rely not on .pot files but rather on scanning the actual framework files with each version — as these matter in the end what gets displayed and what not.


    #11211

    David Decker
    Moderator
    Post count: 93

    @rammen:

    The Translation plugin from Remkus is powered by the community, therefore not an official release. Remkus collects updated translation files for Genesis 1.9.x at the moment. So shortly there should be an update out.

    Please do consider contributing missing strings for your language: see @Remkus reply above for more info or have look at this post: http://www.studiopress.com/forums/topic/genesis-translations/

    THANKS!


    #11252

    Pulppi
    Participant
    Post count: 2

    I added snippet into functions.php and that helped.

    Thank you

Viewing 11 posts - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.