Magazine Pro: Alt-Sidebar Not Appearing

Community Forums Forums Design Tips and Tricks Magazine Pro: Alt-Sidebar Not Appearing

This topic is: not resolved

This topic contains 14 replies, has 2 voices, and was last updated by  Anita 10 months ago.

Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
    Posts
  • #70726

    ithacaindy
    Participant
    Post count: 47

    I’m stumped why the secondary-sidebar won’t appear on my live site, but it does appear on my dev site. The dev site has the same plugins activated and there’s no problem getting the secondary-sidebar to show. When I activate Magazine Pro on my live site, however, the secondary-sidebar doesn’t appear.

    I’ve double checked to make sure the content-sidebar-sidebar default display is selected. I’ve tried sidebar-sidebar-content just to be sure – no go. I’ve cleared the browser cache and the site cache. When I try the live preview of Magazine Pro, both sidebars of the theme do appear. But once I activate the theme, the secondary-sidebar doesn’t appear and the secondary-sidebar isn’t listed when I view the page’s HTML source.

    Any clues?

    http://ithacaindy.org and ithacaindy.com
    #70727

    Anita
    Participant
    Post count: 7582

    Using Firefox, I am able to edit the HTML and type something in there. So it’s there. What type of content do you have in that widget area.


    When asking for help, please provide a link or screen shot showing your problem!
    Let me help you customize your theme, responsive header, Buddypress, Agentpress or technical issue!
    Visit me here: Cre8tiveDiva.com | Tweet Me!

    #70751

    ithacaindy
    Participant
    Post count: 47

    The secondary sidebar has only a widget which lists the recent posts. I’m using Firefox/firebug and the secondary sidebar appears neither in the HTML code nor the page output.

    The secondary-sidebar problem seems limited to the Magazine Pro child theme. I switched the live theme to Eleven40 Pro and both sidebars appear. I switch back to MP and only the main sidebar appears.

    • This reply was modified 10 months ago by  ithacaindy.
    • This reply was modified 10 months ago by  ithacaindy.
    #70796

    Anita
    Participant
    Post count: 7582

    I see the secondary sidebar on here ithacaindy.com with Recent Posts. Now I don’t see the Primary Sidebar. Do you have something in there? Somehow that code doesn’t look right. If you have any content in your widget areas using DIVs, make sure they are closed.


    When asking for help, please provide a link or screen shot showing your problem!
    Let me help you customize your theme, responsive header, Buddypress, Agentpress or technical issue!
    Visit me here: Cre8tiveDiva.com | Tweet Me!

    #70811

    ithacaindy
    Participant
    Post count: 47

    The sidebar appears fine on my dev server — ithacaindy.com. The problem is with my live server — ithacaindy.org –which because it is live has a different theme running most times. However, when I switch to Mag Pro, the secondary sidebar never appears. The secondary sidebar will appear in the “live” theme preview, but not after the theme is activated. When Mag Pro is activated it is running the stock child theme with no modifications.

    #70812

    Anita
    Participant
    Post count: 7582

    This is what I see in Firefox – http://awesomescreenshot.com/0721ww1n30. I see the Content area – the blank area in the middle is where the Primary Sidebar goes and the last column is the Secondary Sidebar.


    When asking for help, please provide a link or screen shot showing your problem!
    Let me help you customize your theme, responsive header, Buddypress, Agentpress or technical issue!
    Visit me here: Cre8tiveDiva.com | Tweet Me!

    #70814

    ithacaindy
    Participant
    Post count: 47

    Yep. That is the dev site – which works fine. On the live site with the exact same theme, the exact same plugins and the exact same widgets, the secondary sidebar does not appear nor does it show in the HTML source – meaning it is not even generated. I can switch to another child theme and the secondary sidebar of that theme appears.

    #70818

    Anita
    Participant
    Post count: 7582

    Where is the LIVE site so I can take a look?


    When asking for help, please provide a link or screen shot showing your problem!
    Let me help you customize your theme, responsive header, Buddypress, Agentpress or technical issue!
    Visit me here: Cre8tiveDiva.com | Tweet Me!

    #70819

    ithacaindy
    Participant
    Post count: 47

    ithacaindy.org. The Mag Pro theme will be online until noon eastern so you can check it out.

    #70820

    ithacaindy
    Participant
    Post count: 47

    Interesting. The secondary sidebar appears on the single post page, but not the home page.

    #70821

    ithacaindy
    Participant
    Post count: 47

    I fixed it. the .frontpage file was forcing the content-sidebar layout. I commented that out and the secondary sidebar appears.

    #70825

    Anita
    Participant
    Post count: 7582

    The home page needs to be configured for content-sidebar-sidebar. It’s currently set to content-sidebar. If you want to “force the layout” of the home page copy this into your Functions.php file:

    //* Force content-sidebar-sidebar layout setting
    add_filter( 'genesis_pre_get_option_site_layout', '__genesis_return_content_sidebar_sidebar' );

    At the end of the line make sure there is an – ;


    When asking for help, please provide a link or screen shot showing your problem!
    Let me help you customize your theme, responsive header, Buddypress, Agentpress or technical issue!
    Visit me here: Cre8tiveDiva.com | Tweet Me!

    • This reply was modified 10 months ago by  Anita.
    • This reply was modified 10 months ago by  Anita.
    • This reply was modified 10 months ago by  Anita.
    • This reply was modified 10 months ago by  Anita.
    • This reply was modified 10 months ago by  Anita.
    • This reply was modified 10 months ago by  Anita.
    • This reply was modified 10 months ago by  Anita.
    • This reply was modified 10 months ago by  Anita.
    • This reply was modified 10 months ago by  Anita.
    • This reply was modified 10 months ago by  Anita.
    #70831

    Anita
    Participant
    Post count: 7582

    Don’t use my code, it’s broken. This dang thing strips code. Go here – http://my.studiopress.com/snippets/admin-management/. The first section is Force Layout Settings. Look for content-sidebar-sidebar. You don’t need the entire box.


    When asking for help, please provide a link or screen shot showing your problem!
    Let me help you customize your theme, responsive header, Buddypress, Agentpress or technical issue!
    Visit me here: Cre8tiveDiva.com | Tweet Me!

    #70836

    Anita
    Participant
    Post count: 7582

    Ok, I got the code to work correctly now –

    //* Force content-sidebar-sidebar layout setting
    add_filter( 'genesis_pre_get_option_site_layout', '__genesis_return_content_sidebar_sidebar' );

    When asking for help, please provide a link or screen shot showing your problem!
    Let me help you customize your theme, responsive header, Buddypress, Agentpress or technical issue!
    Visit me here: Cre8tiveDiva.com | Tweet Me!

    #70842

    Anita
    Participant
    Post count: 7582

    Glad you got it working.


    When asking for help, please provide a link or screen shot showing your problem!
    Let me help you customize your theme, responsive header, Buddypress, Agentpress or technical issue!
    Visit me here: Cre8tiveDiva.com | Tweet Me!

Viewing 15 posts - 1 through 15 (of 15 total)

You must be logged in to reply to this topic.