magazine theme – [...] does not work

Community Forums Forums Design Tips and Tricks magazine theme – [...] does not work

This topic is: resolved

This topic contains 5 replies, has 2 voices, and was last updated by  laura 1 year, 3 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #11739

    laura
    Participant
    Post count: 69

    I installed the magazine theme and changed the text of the sample Hello world page (so any visitors get something about my website while I figure out how wordpress works).  However the [...] at the end of the post snippet does not work?

    How do I correct this?

    Thank you!

    #11740

    laura
    Participant
    Post count: 69

    Should have added that the website is momgoesonline.com

     

    #11753

    Bill Murray
    Participant
    Post count: 572

    Doen’t work to do what – be an active link? See the WP codex on customizing the read more tag.

    By default on an excerpt, the [...] is not an active link. See your Genesis->Theme Settings for your default archive settings. This encourages users to click on the post title to read more. If you want a separate more link or a button, consider using either the content limit or putting a custom more tag at the spot where you want it in each post.


    Web: http://wpperform.com or Twitter: @wpperform

    We do managed WordPress hosting.

    #11754

    laura
    Participant
    Post count: 69

    Hi Bill – thx so much for your reply.  Although I must admit I only understand about half of it (I am a complete novice + a technical gnat…:-( )

    I would like it to work like the demo http://demo.studiopress.com/magazine/

    In the demo you can link to the article from the title, as you suggest, as well as at the end of the snippet, where you get ” …[read more]“, and the [read more] part links to the rest of your post.

    Hope that makes sense?

    #11760

    Bill Murray
    Participant
    Post count: 572

    I only understand 1/4 of what I write, so if you get 1/2, you’re doing well :)

    Take another read of my previous reply and visit your Genesis->Theme Settings and toward the bottom you’ll see a meta box for Content Archives. I suspect this is set to Excerpt for your site now.

    The link I included is jargon-filled, but one takeaway is that for an excerpt, the ellipsis (the …) is not a link. That’s why it’s not a link for your site. That in turn leads to how to change it. To do that, adjust your settings in that meta box to display post content. That will open up a new setting where you can control how many characters of content display on an archive (which is what is displaying in a list of posts). The standard excerpt is 55 characters, but you can set it to whatever works best for your site. That should allow a clickable more link after the amount of content you want is displayed.

    Another takeaway from that article is that you can insert a custom more tag in a post if you want to make everything truly custom. You can also alter the “Read More” text by PHP code. For most, this is more effort than it’s worth, but ultimately it’s your call.


    Web: http://wpperform.com or Twitter: @wpperform

    We do managed WordPress hosting.

    #11763

    laura
    Participant
    Post count: 69

    Well, you should give yourself more credit: this time I understood 100% of what you wrote, and it worked :-)

    Thank you for taking the time to explain it to me!

Viewing 6 posts - 1 through 6 (of 6 total)

The topic ‘magazine theme – [...] does not work’ is closed to new replies.