Make "blog" the front page of Minimum Theme

Community Forums Forums General Discussion Make "blog" the front page of Minimum Theme

This topic is: not resolved

This topic contains 17 replies, has 2 voices, and was last updated by  Susan Nelson 1 year, 5 months ago.

Viewing 15 posts - 1 through 15 (of 18 total)
  • Author
    Posts
  • #31996

    strange_cathet
    Participant
    Post count: 12

    I don’t want the gigantic picture on the front page of my site. Instead, I’d like to have the theme display all my blog posts. Like this example:

    http://demo.studiopress.com/minimum/layouts/cs/

    How can I do that?

    #32001

    Susan Nelson
    Participant
    Post count: 207

    Hi there,

    I’m thinking it should work if you disable the home.php file. I would rename it to something like -home.php instead of deleting it just in case you change your mind and decide to use it.

    Let me know if that works.


    Susan Nelson | Oh, Hello Designs | Twitter | Facebook

    #32002

    Susan Nelson
    Participant
    Post count: 207

    Or….just don’t put any widgets in the home page widget areas. If you leave them empty, it should just default to the regular list of blog posts.


    Susan Nelson | Oh, Hello Designs | Twitter | Facebook

    #32034

    strange_cathet
    Participant
    Post count: 12

    Hi Susan. Thanks, but neither of those solutions worked. Any other ideas?

     

    #32035

    Susan Nelson
    Participant
    Post count: 207

    Can you show me a link to your site so I can check it out?


    Susan Nelson | Oh, Hello Designs | Twitter | Facebook

    #32037

    strange_cathet
    Participant
    Post count: 12

    Sure,

    http://opensourcewriting.org/

    However, I’ve added back the widgets to the primary widgit area now…

    #32042

    Susan Nelson
    Participant
    Post count: 207

    I’m looking at the home.php file of the theme and it says this near the top:

    Add widget support for homepage. If no widgets active, display the default loop.

    That means that if you do not put widgets into the home page widget areas, you should just see the regular list of blog posts. Can you go ahead and take those widgets out and then let me know so I can see what’s happening?


    Susan Nelson | Oh, Hello Designs | Twitter | Facebook

    #32046

    strange_cathet
    Participant
    Post count: 12

    Ok, Susan. There are no widgets in any portion of the homepage. It is still presenting the home page with “snippet” previews of the blog posts.

    I’m also noticing if I try to view all the blog posts by clicking “posts” in the breadcrumb trail, I get a list of all the posts, but the child theme seems to malfunction in the process.

    http://opensourcewriting.org/category/posts/

    {This is a brand-new install as of yesterday and I haven’t changed any .php}

    #32048

    Susan Nelson
    Participant
    Post count: 207

    Can you also rename home.php so that it’s totally inactive? I’d like to see what happens then.

    Also, to make the large image go away, you can go to line 447 in style.css and add display: none; (in bold below).

    /* Featured Image
    ———————————————————— */

    #featured-image {
    display: none;
    text-align: center;
    width: 100%;
    }


    Susan Nelson | Oh, Hello Designs | Twitter | Facebook

    #32049

    strange_cathet
    Participant
    Post count: 12

    I’ve now disabled home.php on the Minimum child theme. Or do you mean in the Genesis theme?

    Thanks for the tip on the image!

    #32051

    Susan Nelson
    Participant
    Post count: 207

    I meant the Minimum theme. How strange! I don’t know why that is happening.

    Here’s another solution that might work for you. Create a new page and set the template to the Blog page. Then go to Settings > Reading > and set that new page as your front page. If you do it this way, you won’t need to fiddle with home.php or setting the featured image to display: none.


    Susan Nelson | Oh, Hello Designs | Twitter | Facebook

    #32055

    strange_cathet
    Participant
    Post count: 12

    So, I choose “static” page. Then choose the page I created, named “Blog” as the static page. That seems to work ok but it isn’t honoring my setting for the number of blog posts to display. And I’m still having problems with the child theme not working when I view all the post categories, like this:

    http://opensourcewriting.org/category/posts/

    Is this some kind of bug in the theme. It isn’t really working out as I had hoped.

    #32058

    strange_cathet
    Participant
    Post count: 12

    There definitely seems to be an issue with the breadcrumbs. I just added them to the “posts” category and the blog page we set as the front page lost all the child theme formatting as a result.

    #32071

    strange_cathet
    Participant
    Post count: 12

    Ok. So I was wrong about the breadcrumbs. It seems to be the blog template itself. Any page that I save as a blog template loses all of the child theme settings…

    #32082

    strange_cathet
    Participant
    Post count: 12

    I guess I would be happy right now if I could just get the blog template to work properly. I’ve isolated the problem.

    I have created a page named “Blog” and set it to use the Blog template. As long as I tell it to only display an excerpt of posts, the correct child theme formatting is displayed. However, if I ask it to present the full post content, the formatting disappears and it looks horrible. You can see the result here:
    http://www.opensourcewriting.org/blog

Viewing 15 posts - 1 through 15 (of 18 total)

You must be logged in to reply to this topic.