Menu help – Metro Theme

Community Forums Forums Design Tips and Tricks Menu help – Metro Theme

This topic is: not resolved

This topic contains 27 replies, has 3 voices, and was last updated by  tinstar 1 year, 12 months ago.

Viewing 15 posts - 1 through 15 (of 28 total)
  • Author
    Posts
  • #54088

    angieatc
    Participant

    I am having 2 issues with the menu on the Metro theme.

    1. How do I make the Subnav wider? I cannot find anywhere to increase the width of it.
    2. My Subnav text does not show up like it does on the demo.

    Thanks


    My design site, Hill Springs Designs

    http://testsite.strosgirldesigns.com/
    #54100

    AC
    Blocked

    For your Subnav – are you meaning that there isn’t a HOVER COLOR? If so, change this to whatever color you want.

    .genesis-nav-menu li li a:hover {
        background-color: #F96E5B;
    }

    I am still hunting for the wider Subnav. For the life of me I cannot find it either! I’ll keep looking.

    #54101

    AC
    Blocked

    If I change “auto” to 50% – it widens, but not on your site. That top “Services” tab will not drop down.

    .menu-secondary, #header .genesis-nav-menu {
        float: right;
        width: auto;
    }
    #54106

    angieatc
    Participant

    AHA thanks! I looked at that but was not sure about it.

    I am talking about the text area on the left hand side. If you look at the demo here you can see the text on the left hand side on the sub-nav, this is the area I am talking about.


    My design site, Hill Springs Designs

    #54108

    angieatc
    Participant

    And what is weird, is if I move the tab services out from the 1st slot on the menu the menu looks fine but if I leave it in the 1st position it goes to the top line and moves everything down. WEIRD


    My design site, Hill Springs Designs

    #54111

    AC
    Blocked

    Did you follow these instructions from the my.studiopress.com Get Started?

    How to Configure the Navigation

    To set up the menu items in the Primary Navigation please see How to Set Up Menus.

    For the date on the right, go to Genesis -> Settings -> Navigation. Check the box to use Nav Extras. Pick the date from the drop down.

    The menu at the top of the screen is the Secondary nav menu slot. There is a Subnav Left widget area where we used a text widget.

    #54116

    angieatc
    Participant

    The primary navigation is correct it is the yellow menu.

    And for the secondary nav menu slot I put a text widget there, that is what it says and yes I followed the directions, that is why I am confused.


    My design site, Hill Springs Designs

    #54118

    AC
    Blocked

    Ok, just making sure because I wasn’t quite seeing that in the CSS when I used Firebug. You don’t have it in place now so I can target it.

    #54120

    angieatc
    Participant

    That is where I am confused because I do have the widget in place in my widgets section.


    My design site, Hill Springs Designs

    #54121

    AC
    Blocked

    Girl… I am about to pull my hair out. So… you have a Text Box with text in it in the Subnav Left widget area. That area is in the widget area. I just got it to work over here – http://cre8tivediva.com/metrobp

    #54129

    angieatc
    Participant

    WHAT?!?!

    Here is what I have, you can see the screen shot here


    My design site, Hill Springs Designs

    #54130

    AC
    Blocked

    That’s weird. I just copied my style sheet to yours site in Firebug and it’s still missing so I think it some code the function area. Did you modify that at all?

    #54136

    AC
    Blocked

    Check your functions area for this – see if yours looks the same:

    // Reposition the secondary navigation
    remove_action( ‘genesis_after_header’, ‘genesis_do_subnav’ );
    add_action( ‘genesis_before’, ‘genesis_do_subnav’ );
    
    // Adds widget area before the .menu on #subnav
    add_filter( ‘genesis_do_subnav’, ‘child_do_subnav_widget’, 10, 2 );
    function child_do_subnav_widget( $subnav_output, $subnav ){
    	ob_start();
    	genesis_widget_area( ‘subnav-left’, array(
    		‘before’ => ‘<div class="subnav-left widget-area">’,
    	) );
    	$widget_area = ob_get_clean();
    
    	return str_replace( $subnav, $widget_area . $subnav, $subnav_output );
    }
    #54141

    tinstar
    Participant

    I’m having the exact same problem. I have a text widget in place and copied the code you have above in my functions.php file just to be sure. (They were the same.)

    #54142

    AC
    Blocked

    @tinstar, what’s your URL, let me look.

Viewing 15 posts - 1 through 15 (of 28 total)

You must be logged in to reply to this topic.