Menu item appearing in both menus?

Community Forums Forums Design Tips and Tricks Menu item appearing in both menus?

This topic is: resolved

This topic contains 8 replies, has 2 voices, and was last updated by  willyr 1 year, 7 months ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #11329

    willyr
    Participant
    Post count: 36

    OK, I’m a bit stumped.

    URL: http://orlando-florida-attractions.com/

    The link to the contact page is appearing in both the Main menu and the Side menu, though, on the dashboard, the link is only on the Side menu.

    Anyone have any idea why this is happening?

    Thanks,

    Bill

     

    #11335

    media317
    Participant
    Post count: 52

    Unless you create a custom menu in Appearance>Menu, every page you create will default to your main navigation.  Here is how to do it.


    Alan Smith
    Media317

    #11339

    willyr
    Participant
    Post count: 36

    Alan, I sure appreciate the fast reply.

    Unfortunately, I have done all of that. I have two menus, Main and Side.

    The link to the contact page is only in the Side menu, not in the Main menu.

    Yet the contact menu item appears in both. Am I missing a step…. probably! :-)

    Bill

    #11347

    media317
    Participant
    Post count: 52

    Do you have Main in the drop down in Appearance>Menus under Primary Navigation?


    Alan Smith
    Media317

    #11348

    willyr
    Participant
    Post count: 36

    Yes.

    #11352

    willyr
    Participant
    Post count: 36

    If I add the menu item to the side menu, it also appears in the Main top menu, but on a new line.

    If I add a new page link to the Main menu, it appears on the same line as the existing nav items, but the weird link to the contact page starts it’s own line below the others.

    If I delete the contact menu item from the Side menu, it also disappears from the Main top menu.

    Very weird. This is the fourth or fifth menu I’ve built on a variety of sites, and I can’t recall this happening before.

    Bill

    #11353

    willyr
    Participant
    Post count: 36

    So, what I’ve done, is created a link using html and put it into a text widget in the right column.

    http://www.orlando-florida-attractions.com

    This is a work around, and I’m very puzzled as I have not had this problem before.

    If no one has any suggestions, I’ll ask support to have a look when they have a moment.

    Thanks for any and all help.

    Bill

    #11403

    media317
    Participant
    Post count: 52

    There are some themes that are picky about the name.  I’ve had to actually name my meny “Primary” and “Secondary” in some themes to get them to work properly.  Try renaming them.


    Alan Smith
    Media317

    #11444

    willyr
    Participant
    Post count: 36

    Alan, thanks your ongoing support.

    I am really, really embarrassed about a silly mistake. There actually is nothing wrong.

    I took your tip and created new menus. In so doing I removed the menu name from the Secondary Navigation field on the Menus page, and, of course, the secondary navigation menu, which I now know appears under the primary menu at the top of the page, is now gone.

    Duh!!!

    So sorry about bothering you. Thanks to all for reading and for helping.

    Cheers,

    Bill

Viewing 9 posts - 1 through 9 (of 9 total)

The topic ‘Menu item appearing in both menus?’ is closed to new replies.