Menu Problem

Community Forums Forums General Discussion Menu Problem

This topic is: not resolved

This topic contains 4 replies, has 3 voices, and was last updated by  kevinharper 2 weeks, 1 day ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #100973

    RRG
    Participant
    Post count: 2

    I have agentpress and I’m using WordPress 3.9 and running into a problem with my primary navigation menu. I have several links to listing by features, neighborhoods, etc… Anyway, I added another neighborhood link to my primary menu and it threw my primary menu in chaos. It completely deleted my last link and then removed the URL from the bottom link, so the text was there but you couldn’t click on it.

    Also, when I went to save the menu, it would “unassign” it from the primary navigation menu and I would have to go back in and assign it again (with last link (and text) misssing and then the URL portion missing from the next link up (but the text was there)

    I had to delete my “search by price range” menu and submenus to get it to work right. Does this make any sense?

    It’s working fine now, but under my “browse listing” I don’t have the option to browse by price range anymore, I had to remove links to get the menu to work right again.

    Is there some kind of limit on the number of links I can have on the navigation menus?

    Thanks!

    http://My website is http://www.russellrealtygroup.com
    #101127

    RRG
    Participant
    Post count: 2

    Cany anyone help me?

    #101208

    CalliaWeb
    Participant
    Post count: 6

    Hi RRG

    I’ve run into this issue a couple of times. It is a setting on your web server that needs adjusting. You need to request that your web hosting support increase the max_input_vars value in the php.ini.

    You can use Gary Jones’ plugin Diagnosis – http://wordpress.org/plugins/diagnosis/ – to see what it is currently set at.

    I hope that helps.
    Cheers
    Jo

    #127145

    kevinharper
    Member
    Post count: 2

    I ran into this problem and it was not solved by changing max_input_vars.

    With “max_input_vars = 9000″ I was able to get up to 90 menu items, so I thought maybe there was a 100:1 correlation, but I upped it again to 20000 and it still did not work. I have checked using phpinfo.php to make sure my settings are active.

    For the sake of anyone trying to solve this UNVSOLVED issue, here are the details of my case:

    Host: Hostgator
    PHP version: 5.5
    Wordpress version: 4.0
    max_input_vars = 20000
    Theme: Genesis / Turn Key Slider

    I have 90 menu items in the primary menu, out of which only 6 are top level, 58 are second level, and 26 are third level.

    All I want to do is add 2 more top level items, but when I do so and click save, the new items don’t get saved, and the Primary Menu flag gets deselected.

    If anyone has any insight on this, please help!


    Real Estate SEO
    http://realestateseo.biz

    #127158

    kevinharper
    Member
    Post count: 2

    PROBLEM SOLVED.

    The issue in my case was a peculiarity of how HostGator handles php.ini customizations.


    Real Estate SEO
    http://realestateseo.biz

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.