Metro Customisations

Community Forums Forums Design Tips and Tricks Metro Customisations

This topic is: not resolved


This topic contains 6 replies, has 6 voices, and was last updated by  cotaylo 2 years, 4 months ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
  • #34948


    I have changed over to the Metro theme but it seems you don’ have the ability to put a logo top left?

    Can anyone advise how I could get a graphic to show top left?

    Also I would like to put a menu at the very top of the site as they have done here –

    And finally he seems to have made his main content a little bit transparent?

    Any tips on any of this would be appreciated





    You can use the Header function for this. Go to Appearance > Editor. Select Functions and look for this:

    // Add support for custom header
    add_theme_support( ‘genesis-custom-header’, array(
    	‘flex-height’	=> true,
    	‘height’		=> 87,
    	‘width’			=> 1080
    ) );

    Change the height and width to the size of your logo. This will give the header function the correct size and you will not need to crop anything.

    Then go to Appearance > Header.
    Upload your header.

    That’s it.

    To activate the top menu – that is the Secondary Menu. Go to Genesis > Theme Settings. Make sure you have activated the Secondary Menu.

    Then head over to Appearance > Menus. Create a menu for the top nav and allocate that to the Secondary Nav on the left of that screen. Be sure to save everything.

    For the transparency… I have to look that one up and get back to you.


    bill scheider

    Hi Roger,
    The transparency was accomplished in the photography site by adding this to the #wrap:
    background-color: rgba(0, 0, 0, 0.8);

    The ‘a’ at the end of the rgb stands for alpha. Adjusting that number adjusts the transparency.



    I have a similar question to this one. When I go to upload my custom header, part of the original one remains. How do I remove the original header style and just use my custom header?



    I have the same issue as socialprguy.

    If I uncheck “Show header text with your image” then my logo also disappears and I just get a large blue full width box in the header.

    If I leave it checked, then I get the original text over top of my logo…

    You can see that here:

    Thanks for the input!




    Thanks Marc but any chance there is a simpler answer?

    I mean, really, I just uploaded my logo via Appearance > Background. Why do I need to add all that code to fix that overlapping theme glitch?

    I was expecting a little more user friendliness with the Studiopress themes. :(

    I haven’t changed any code yet – the theme is straight out of the box so to speak and already I have this problem that I have to add code for?

    • This reply was modified 2 years, 4 months ago by  cotaylo.
    • This reply was modified 2 years, 4 months ago by  cotaylo.
Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.