Metro Menu

This topic is: not resolved

Tagged: 

This topic contains 16 replies, has 5 voices, and was last updated by  Susan 1 year, 5 months ago.

Viewing 15 posts - 1 through 15 (of 17 total)
  • Author
    Posts
  • #23455

    merlinberg
    Participant
    Post count: 21

    This is my first time on this forum.  I have a problem with the way the menu display.  I’ve very carefully followed the guidance in tutorials.  After setting up a custom  menu and activate the menu the display on the page show the menu items vertical rather than horizonal.  For example

    Home
    Page 1
    Page 2
    Page 3

    I’m really stuck. Can’t get the menu to display horizontally

    Home   Page 1   Page 2   Page 3

    I would appreciate any help you can give me.  Thanks, Merlin

    #23513

    Susan
    Moderator
    Post count: 8711

    Can you please post a link to your site?

    Did you indent the pages under your home menu item?


    Susan @ Graphically Designing I’d love to customize your website! I tweet!
    I’ve taken up the challenge! – help me answer some of the unanswered posts

    #23557

    merlinberg
    Participant
    Post count: 21

    Susan,  the link to my site http://merlin-berg-enterprises.info

    The pages were not indented under the home menu item.  I just tried to indent menu items under home.  Did not work.

    #23611

    Susan
    Moderator
    Post count: 8711

    Merlin:

    I just took a look at your site – You’ve indicated you followed the set-up instructions:
    http://my.studiopress.com/tutorials/use-navigation-menus/

    When you are on the menus screen, do your pages look like they do in the link above? If not, is it possible to post a screenshot here for me to look at? (You can upload a screenshot to your media library, and post the link on the forum here).

    (edited to add – for what it’s worth, my site is built on the Metro theme, and here’s how my menu set-up was done: screenshot)


    Susan @ Graphically Designing I’d love to customize your website! I tweet!
    I’ve taken up the challenge! – help me answer some of the unanswered posts

    #23666

    merlinberg
    Participant
    Post count: 21

    Susan, my menus screen looks exactly like yours.  ??

     

    #23669

    Susan
    Moderator
    Post count: 8711

    You indicated you created a “custom menu”. Did you drag a custom menu widget into a widget area on the site?

    I’m sure it’s probably a simple fix, but without getting under the hood so to speak, I’m not sure what to recommend from here, other than submitting a support ticket, as it’s a site set-up question.

    http://my.studiopress.com/help/


    Susan @ Graphically Designing I’d love to customize your website! I tweet!
    I’ve taken up the challenge! – help me answer some of the unanswered posts

    #23678

    Hard Boiled Greg
    Participant
    Post count: 88

    Hey guys,

    Merlin, are you running Genesis 1.9.1?

    Hard Boiled Greg


    Website: Hard Boiled Greg Twitter: @hbgreg

    #23772

    merlinberg
    Participant
    Post count: 21

    Greg, I just checked the site and I’m using Genesis 1.9.1.  Thank you

    #23777

    merlinberg
    Participant
    Post count: 21

    Susan, Yes I did drag the custom menu widget into into the header and made sure it was on ‘custom 2″.  Thank you for all your help.  Since I don’t have any content on these pages, I’m going to delete the theme and reload. –  Merlin

    #23778

    Riavon
    Participant
    Post count: 95

    I quickly glanced at your site with Firebug and it appears that the styles for the menu may be missing. I did not see the .genesis-nav-menu.menu-primary around line 870 in your stylesheet, or the .genesis-nav-menu li around line 879 in your stylesheet, which would need to be in your stylesheet to enable the menu to display like it does on the Metro theme demo.

    Did you perhaps accidentally delete these from your stylesheet? If so, try placing the following into your stylesheet and see if that helps you resolve this issue.

    .genesis-nav-menu.menu-primary {
    background-color: #333333;
    }

    .genesis-nav-menu li {
    display: inline-block;
    float: left;
    list-style-type: none;
    text-align: left;
    }

    .genesis-nav-menu a {
    display: block;
    padding: 1rem 1.25rem 0.875rem;
    position: relative;
    }

    (Or, reloading the theme – good idea!) Let us know how it works out!


    Twitter: @riavonentprises

    #23780

    Susan
    Moderator
    Post count: 8711

    Yes I did drag the custom menu widget into into the header

    You don’t need to drag it into a Widget area. Go ahead and look at my screenshot in my earlier post. To the left side of the image, you can see a drop-down where it says “Primary Navigation” – select the custom menu from that drop down, save the changes, and it should populate correctly.

    (Another screenshot here)


    Susan @ Graphically Designing I’d love to customize your website! I tweet!
    I’ve taken up the challenge! – help me answer some of the unanswered posts

    #23844

    majecdad
    Participant
    Post count: 8

    I am having the same issues as Merlin.

    I have:

    Genesis 1.9.1
    Deleted the Metro theme and reinstalled, twice now, once from wordpress, once from ftp.
    Checked the .css and yes it has the code Riavon mentioned.
    Quintuple checked my menus, even creating fresh ones. Layout is correct. Settings are correct. Shows menus and changes.
    Dropped my laptop out the second floor window – ok, didn’t really do that last one, but felt like it. :)
    Still, the menus show up, vertically, and with bullets.
    Amazing that can be this frustrating.

    Sorry to not be able to link to site, locked down client test site. But take my word for it. :)

    One more tidbit, this same exact thing happens with Genesis ‘Sample’ (1.9), the default child for the 1.9.1 framework, but does NOT happen when I go back to Backcountry, my former theme.

     

    #23847

    Susan
    Moderator
    Post count: 8711

    @majecdad – Merlin indicated that she dragged a Custom Menu into her header widget area. Did you do the same thing? If so, remove it. You don’t have to drag a custom menu anywhere. You need to select the menu you wish to appear under “Primary Navigation”.


    Susan @ Graphically Designing I’d love to customize your website! I tweet!
    I’ve taken up the challenge! – help me answer some of the unanswered posts

    #23857

    majecdad
    Participant
    Post count: 8

    @susan – thanks for the reply. No, I did not drag widgets like that. I simply structured the Appearance / Menus / Theme Locations to state which menus were to show where. Again, the menus showed in their respective places, but did so vertically and with a list-style-type: circle.

    And without changing anything menu wise, it displays totally correctly in Backcountry theme (but not in either Metro or Sample).

    Weird.

     

    #23858

    Susan
    Moderator
    Post count: 8711

    It is weird; I’m running the Metro theme myself. I recommend submitting a support ticket at this point, as it is set-up related. I would be interested in knowing what they have to say, because it is perplexing!


    Susan @ Graphically Designing I’d love to customize your website! I tweet!
    I’ve taken up the challenge! – help me answer some of the unanswered posts

Viewing 15 posts - 1 through 15 (of 17 total)

You must be logged in to reply to this topic.