Metro stop flashing background?

Community Forums Forums Design Tips and Tricks Metro stop flashing background?

This topic is: not resolved

This topic contains 3 replies, has 3 voices, and was last updated by  vivianleemit 1 year, 6 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #21873

    TravisPri
    Participant
    Post count: 29

    Hi there, I’m about to get started developing a client site and trying to decide what theme to use.

    I really like Metro, but I don’t like the way that the background flashes every time you load a new page. Any idea if that is something that can be turned off pretty easily? Delete something somewhere?

    Thanks!

     

    #21881

    Sridhar Katakam
    Participant
    Post count: 993

    To turn off background flashing,

    In child theme’s functions.php, comment out

    [php]
    add_theme_support( ‘custom-background’, array( ‘wp-head-callback’ => ‘__return_false’ ) );
    [/php]

    and

    [php]
    add_action( ‘wp_enqueue_scripts’, ‘metro_enqueue_scripts’ );
    [/php]

    Then use this sample CSS:

    [css]
    body {
    background: url(‘images/body-bkgrd.jpg’) no-repeat center center fixed;
    -webkit-background-size: cover;
    -moz-background-size: cover;
    -o-background-size: cover;
    background-size: cover;
    }
    [/css]


    #21882

    TravisPri
    Participant
    Post count: 29

    Love it. Thanks!

    #23621

    vivianleemit
    Participant
    Post count: 3

    I used the code, direct copy-paste, and still get the flashing :(

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.