Midnight theme posts issue

Community Forums Forums General Discussion Midnight theme posts issue

This topic is: resolved

This topic contains 7 replies, has 3 voices, and was last updated by  hguillaume 1 year, 7 months ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #23452

    thedesertlynx
    Participant
    Post count: 3

    Hello,

    I use the Midnight Child Theme for my blog, and managed to make the front page display the latest posts. However, when I click “Older Posts” at the bottom, while the URL changes to “/page/2/”, the posts displaying are the same as on the front page. Any ideas on how to fix this?

    Site is thedesertlynx.com.

    Thank you!

    #23677

    Hard Boiled Greg
    Participant
    Post count: 88

    Hi,

    How are your reading settings configured? It appears are you using a blog page template and then setting that to be the static front-page under reading settings? If you are older/newer doesn’t work on pages.

    Hard Boiled Greg


    Website: Hard Boiled Greg Twitter: @hbgreg

    #23680

    thedesertlynx
    Participant
    Post count: 3

    That is correct. How can I get older/newer to work with a similar configuration? The Midnight Theme default posts page is pure rubbish.

    #23681

    Hard Boiled Greg
    Participant
    Post count: 88

    It doesn’t look like the Midnight theme is still available so I can’t look at it’s default. How is the posts page different?

    HBG


    Website: Hard Boiled Greg Twitter: @hbgreg

    #23682

    thedesertlynx
    Participant
    Post count: 3

    Check out the demo. This is the posts/home page, which actually doesn’t seem to function as a proper posts page at all:

    http://demo.studiopress.com/midnight/

    #23683

    Hard Boiled Greg
    Participant
    Post count: 88

    There’s a few things you could do, but perhaps the simplest would be to rename the home.php file in your theme folder. Then set your reading settings to display latest posts and see if it doesn’t look the same as it does now.

    Let me know.

    HBG


    Website: Hard Boiled Greg Twitter: @hbgreg

    #23685

    thedesertlynx
    Participant
    Post count: 3

    Success. Thank you very much!

    #32786

    hguillaume
    Participant
    Post count: 1

    Changing the home.php file worked for me too (family tree theme).  Thanks!

     

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.