Minimum – Blog Pages/Featured Photo

Community Forums Forums Design Tips and Tricks Minimum – Blog Pages/Featured Photo

This topic is: resolved

This topic contains 9 replies, has 3 voices, and was last updated by  cehwitham 1 year, 8 months ago.

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #19929

    KBordonaro
    Participant
    Post count: 22

    Hi, I’m having some problems with the featured images showing on my blog posts and making the page go out of wack.

    I read in another post that featured images need to be 600 pixels.

    Is there a way to do this without having to manually go through all of my blogs featured images?

    -or-

    Is there a way to simply remove the featured images from showing in the top portion?

    Thanks!

    Kimberly

    #21305

    cehwitham
    Participant
    Post count: 396

    Hi Kimberly,

    I’ve had a look at your site (got the link from one of your other posts) but I can’t see a page where this is an issue.

    Either resizing the images all at once using Regenerate Thumbnails plugin ( http://wordpress.org/extend/plugins/regenerate-thumbnails/ ) or unhooking the images would be easy enough but I could be more specific if I could see where it was messing up.

    Chris


    Twitter: cehwitham Web: cehwitham.com

    #21495

    KBordonaro
    Participant
    Post count: 22

    Hi, Chris!

    Thanks so much for getting back to me.

    There were crickets, so somehow I ended up figuring out how to disable featured images on the blog posts.

    I appreciate your help and will check out the regenerate thumbnail pluggins for the future.

    You rock,

    Kimberly

    #21525

    cehwitham
    Participant
    Post count: 396

    Glad you got it sorted Kimberly.


    Twitter: cehwitham Web: cehwitham.com

    #21590

    QUESTIONM
    Participant
    Post count: 9

    Hey I’m actually having the same problem that Kimberley was. I’d love to know just how to remove the featured image from showing up in the top portion but still be able to keep the home page looking the way it does. I tried getting rid of….

    /** Add the featured image section */
    add_action( ‘genesis_after_header’, ‘minimum_featured_image’ );
    function minimum_featured_image() {
    if ( is_home() ) {
    echo ‘<div id=”featured-image”><img src=”‘. get_stylesheet_directory_uri() . ‘/images/sample.jpg” /></div>’;
    }
    elseif ( is_singular( array( ‘post’, ‘page’ ) ) && has_post_thumbnail() ){
    echo ‘<div id=”featured-image”>’;
    echo get_the_post_thumbnail($thumbnail->ID, ‘header’);
    echo ‘</div>’;
    }
    }

    From the functions.php but that was obviously a newbie mistake as like I mentioned it got rid of my homepage pic too :(

    Any help on this would be great

    Regards, Luke S.

    #21704

    cehwitham
    Participant
    Post count: 396

    Hi Luke do you have a link to your site?

    I’m not sure where you’re referring to as the top portion?

    Chris


    Twitter: cehwitham Web: cehwitham.com

    #21902

    QUESTIONM
    Participant
    Post count: 9

    http://fullcirclecontact.com

     

    If you click any post or page the featured image shows up right under the nav bar. I really only wanted the featured image to show up beside the snippet next to post excerpts.

    #21922

    cehwitham
    Participant
    Post count: 396

    Open functions.php in /wp-content/themes/minimum/ and find the following code:

    /** Add the featured image section */
    add_action( 'genesis_after_header', 'minimum_featured_image' );
    function minimum_featured_image() {
    if ( is_home() ) {
    echo '';
    }
    elseif ( is_singular( array( 'post', 'page' ) ) && has_post_thumbnail() ){
    echo '';
    echo get_the_post_thumbnail($thumbnail->ID, 'header');
    echo '';
    }
    }

    You’ll want to remove the elseif section so you have:

    /** Add the featured image section */
    add_action( 'genesis_after_header', 'minimum_featured_image' );
    function minimum_featured_image() {
    if ( is_home() ) {
    echo '';
    }
    }


    Twitter: cehwitham Web: cehwitham.com

    #22096

    QUESTIONM
    Participant
    Post count: 9

    Thanks for the quick help guy!

    I implemented the code but it seems to get rid of the home page image as well :(. I’ll keep tinkering though

    #22101

    cehwitham
    Participant
    Post count: 396

    I’ve just noticed the code I pasted removed the content in the echo ”; statement for outputting the homepage image. If you copy that echo statement from the original code, it should work fine.


    Twitter: cehwitham Web: cehwitham.com

Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.