Minimum Pro: Hompage background scroll

Community Forums Forums General Discussion Minimum Pro: Hompage background scroll

This topic is: resolved

This topic contains 3 replies, has 2 voices, and was last updated by  bandj 1 year, 1 month ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #60480

    beyers13
    Participant
    Post count: 4

    HI,

    I would like my homepage background image to scroll up with the rest of the content. I selected the scroll option in the custom background area but it doesn’t work.

    Thanks for any input!

    #60527

    bandj
    Participant
    Post count: 184

    That theme uses the backstretch jquery plugin for the full background image. I don’t think scrolling is supported.

    You could try getting rid of the reference to loading the backstretch.js in the functions.php file and use the custom background setting.


    #60655

    beyers13
    Participant
    Post count: 4

    I have already tried that to no avail. It for some reason just gives me a white background. What would be the “add_action” for the custom background. Maybe I am putting in the wrong code. There is a home.php along with the functions.php

    #60681

    bandj
    Participant
    Post count: 184

    right, the script is loaded in the front page file, not the functions

    the add for the custom background is already in the functions.php

    this is what adds backstretch and a body class in the front page. I would try deleting this section and then adding an image to the custom background.

    //* Enqueue Backstretch scripts
    wp_enqueue_script( ‘minimum-backstretch’, get_bloginfo( ‘stylesheet_directory’ ) . ‘/js/backstretch.js’, array( ‘jquery’ ), ’1.0.0′ );
    wp_enqueue_script( ‘minimum-backstretch-set’, get_bloginfo(‘stylesheet_directory’).’/js/backstretch-set.js’ , array( ‘jquery’, ‘minimum-backstretch’ ), ’1.0.0′ );
    wp_localize_script( ‘minimum-backstretch-set’, ‘BackStretchImg’, array( ‘src’ => get_background_image() ) );


Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.