Minimum: Show Whole Blog Post on Main Page

Community Forums Forums Design Tips and Tricks Minimum: Show Whole Blog Post on Main Page

This topic is: not resolved

Tagged: , ,

This topic contains 4 replies, has 3 voices, and was last updated by  braddalton 8 months, 1 week ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #53717

    zackdezon
    Participant
    Post count: 1

    Hey guys! I’m working on a Minimum-themed site (http://thefield.zackdezonphotography.com/), and would like the landing page to show whole posts, as opposed to the truncated [Read more] on there by default. I found an example of a successful integration of this somewhere else on the boards, but there were no replies on the thread: Any help?

    Thanks so much!

    http://thefield.zackdezonphotography.com/
    #53719

    braddalton
    Participant
    Post count: 7448

    You could change the settings in the home.php file to show features rather than a grid and set a high content limit.

    add_action( 'genesis_loop', 'minimum_grid_loop_helper' );
    function minimum_grid_loop_helper() {
    
    	if ( function_exists( 'genesis_grid_loop' ) ) {
    		genesis_grid_loop( array(
    			'features' 				=> 10,
    			'feature_image_size' 	=> 'featured',
    			'feature_image_class' 	=> 'post-image',
    			'feature_content_limit' => 2000,
    			'grid_image_size'		=> 0,
    			'grid_image_class'		=> 'alignnone',
    			'grid_content_limit' 	=> 0,
    			'more'					=> __( '[Read more]', 'minimum' ),
    		) );
    	} else {
    		genesis_standard_loop();
    	}
    
    }
    

    Or comment out and remove the grid.


    WordPress Developer & Consultant
    Brad Dalton400+ StudioPress Tutorials & 1200+ Code snippets

    #53727

    zackdezon
    Participant
    Post count: 1

    Hm, that seemed to get me closer, but now the box seems to cancel out any formatting (until you click Read More). Is there a way to display the true full post?

    When I removed the grid, it just gave me a blank body.

    #55944

    amandaotaylor
    Participant
    Post count: 13

    This worked great for me, thanks!

    #55985

    braddalton
    Participant
    Post count: 7448

    Works for me as i tested it locally.

    By default, WordPress removes all HTML tags from excerpts.

    You can add them back using this code.

    https://gist.github.com/braddalton/5995879


    WordPress Developer & Consultant
    Brad Dalton400+ StudioPress Tutorials & 1200+ Code snippets

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.