Modern Portfolio – User Agent Style Sheet

Community Forums Forums Design Tips and Tricks Modern Portfolio – User Agent Style Sheet

This topic is: resolved

This topic contains 5 replies, has 2 voices, and was last updated by  zig 1 year, 5 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #20729

    rasolis
    Participant
    Post count: 15

    Trying to remove the underline, using Chrome’s Inspect element and finding the code:

    a:-webkit-any-link {

    color: -webkit-link;
    text-decoration: underline;
    cursor: auto;

    }

    How do I edit or where is this user agent style.css?

    Thanks!

    http://www.readipress.com

    #20783

    zig
    Participant
    Post count: 3

    It’s using your browser’s stylesheet – hence the “user” wording.

    Try this. In your theme’s stylesheet, find the style for links and add:

    text-decoration: none

    Example:

    a, a:visited{

    text-decoration: none;

    }

    (around line 115 in the modern-portfolio style.css)

    That should fix it.

    #20933

    rasolis
    Participant
    Post count: 15

    Hey Zig -thanks for the info.  I know how to make the changes, just unable to locate it in the CSS.  Normaly I can do an Inspect Elements in Chrome or do Firebug, but it shows “User Agent…” and is related to the webkit.

     

     

    #20937

    zig
    Participant
    Post count: 3

    rasolis – Not sure I made it clear but you WON’T find it in your CSS. The user stylesheet is based off your reader’s browser’s default settings. You want to override this by using the text-decoration: none I described above.

    For example, here’s a generic default stylesheet for the webkit CSS stylesheet: http://trac.webkit.org/browser/trunk/Source/WebCore/css/html.css

    If you scroll down to line 1216, you’ll see that the default for any link is to underline it with the “text-transform: underline” style. By adding “text-transform: none” to your stylesheet, you will override the default and make sure your readers see what you want them to see.

    Hope this makes sense.

    #21475

    rasolis
    Participant
    Post count: 15

    Hey Zig,  you keep saying scroll down but the text link code is not in the modern portfolio css, I just confirmed with support.  So I just have to add my own code. Thanks for the help though.

    I pasted the following

     

    a:link {text-decoration:none;}
    a:visited {text-decoration:none;}
    a:hover {text-decoration: none;}
    a:active {text-decoration:none;}

    Anthony

    #21587

    zig
    Participant
    Post count: 3

    Glad you got it sorted out.

    The link code started on line 115 in the stylesheet.

    Reply back if you need more help.

Viewing 6 posts - 1 through 6 (of 6 total)

The topic ‘Modern Portfolio – User Agent Style Sheet’ is closed to new replies.