Multipage pagination buttons not visible

Community Forums Forums General Discussion Multipage pagination buttons not visible

This topic is: not resolved

This topic contains 18 replies, has 5 voices, and was last updated by  theateradvisor 1 year, 1 month ago.

Viewing 15 posts - 1 through 15 (of 19 total)
  • Author
    Posts
  • #17820

    benconnor
    Participant
    Post count: 26

    Hi guys,

    Would be great if someone could help me with this.

    My post is too long so I set up the nextpage links thing to break it up. The problem is that the pagination buttons are hidden under social media buttons and rating stars so are not immediately visible.

    Here is the post:

    http://benconnormusic.com/bjork-2/

    I want the pagination buttons to appear immediately after the text and in an immediately visible position so readers click to the next page and keep reading.

    If anyone could help me with this I would be very thankful.

    Cheers,

    Ben

    #17850

    SoZo
    Moderator
    Post count: 1573

    You’ll need to edit how the plugins are placing their code.


    John “Nicolas Flamel” Wright | SoZo’s design| John Wright Photography

    #18066

    benconnor
    Participant
    Post count: 26

    Hi SoZo,

    Okay, cool. But how do I do that?

    Also, while the facebook like and rating buttons are plugins, the share buttons aren’t. They came with the theme.

    Is it complicated? Should I be paying someone to change it for me?

    Would I send them the code for the plugins and ask them to alter it for me? What about the share buttons?

    Look forward to hearing from you.

    Cheers,

    Ben

    #18076

    SoZo
    Moderator
    Post count: 1573

    The News theme doesn’t come with share buttons at the bottom of the post. It does have icons to build menu links in the secondary navbar.

    If the plugins don’t have some sort of template tag that you can manually place then you’ll need to contact the plugins’ developers to see if there is something you can do about getting them below all of the post content.

    A work around my be to increase the font size to make them more prominent. Maybe add a background.


    John “Nicolas Flamel” Wright | SoZo’s design| John Wright Photography

    #18098

    benconnor
    Participant
    Post count: 26

    Hi Sozo,

    Oh, you’re right.

    I just realised the share buttons came with the Jetpack plugin a guy told me to install. The rating buttons come from a Rating-Widget plugin and the facebook like button comes from the FBLike Button plugin I installed.

    How does one place a template tag?

    I can go to the edit plugins for each plugin and alter the php, but what code do I look for and how do I alter it?

    Thanks for all your help Sozo!

    Ben

    #18099

    benconnor
    Participant
    Post count: 26

    Oh,

    The alternative of making the font size more prominent is a great idea, but how do I do that?

    Can I do it with a simple CSS alteration or do I need to get into the backend of my host provider and alter some php file?

    Thanks again,

    Ben

    #18245

    SoZo
    Moderator
    Post count: 1573

    Looks like you found the style rule


    John “Nicolas Flamel” Wright | SoZo’s design| John Wright Photography

    #18347

    benconnor
    Participant
    Post count: 26

    Yeah,

    Still doesn’t cut it for me though.

    Think I might have to contact the plugins developers as you suggest. You sure that there isn’t anything that could be done to the theme’s php code or anything?

    Cheers,

    Ben

    #18355

    anitac
    Participant
    Post count: 6407

    My brain hurts!!!! I already knew how to get the Jetpack share buttons to appear at the top of the posts and then I saw this posting. Again, my brain hurts! I found this…. so to keep you from having to figure it all out – I wrote out the instructions and they do work. I did it on my demo site.

    Part 1

    Go to Plugins > Editor
    At the top right, click the drop down arrow and select Jetpack by WordPress.com
    On the right you will see the plugin files. Look for jetpack/modules/sharedaddy.php – click it.
    Then look for jetpack/modules/sharedaddy/sharing-service.php and click it.
    On the main screen – scroll all the way to the very bottom and look for the following code and DELETE them – then save:

    add_filter( 'the_excerpt', 'sharing_display', 19 );
    add_filter( 'the_content', 'sharing_display', 19 );

    Part 2

    Install and activate the Genesis Simple Hooks Plugin
    Then go to Genesis > Genesis Simple Hooks on the menu
    Look for genesis_before_comments under the Comment List Hooks

    Put this in that box:

    <!--?php echo sharing_display(); ?-->

    Click the Execute PHP on this hook box then Save your changes

    The share buttons are now above the comments and your Pages are above the Share buttons.

    I repeat, my brain hurts! LMBO!


    Let me help you customize your theme, responsive header, Buddypress, Agentpress or technical issue!
    Visit me here: Cre8tiveDiva.com | Tweet Me! | Plus Me!
    When asking for help, please provide a link or screen shot showing your problem!

    #18365

    benconnor
    Participant
    Post count: 26

    Ha ha ha :-)

    Firstly, thanks so much for taking the time to put this together for me anitac!

    My brain hurts too!

    Sadly, yours might end up doing so again when you hear this.

    I have done as you instructed – word for word, step by step I swear. Everything appeared as you said it would as I did as you instructed… only, well, the share buttons have disappeared. They are neither under or above the page numbers:

    http://benconnormusic.com/bjork-2/

    When I put the code back in jetpack/modules/sharedaddy/sharing-service.php the share buttons reappear, but unfortunately still above the page buttons :-(

    Is there perhaps one small step you didn’t mention, or… is there perhaps some setting I may need to switch on or off?

    Help me anitac, you’re my only hope :-)

    Ben

    #18367

    benconnor
    Participant
    Post count: 26

    Hmmm,

    One reason it might not have worked is because I’m using Disqus instead of the ordinary comments box.

    Also, I just realised. If it had worked, would it not have appeared above the comments box but below the After Post Ad?

    My brain just keeps on hurting :-)

    Ben

    #18369

    anitac
    Participant
    Post count: 6407

    I think because you are using Disqus – it’s not recognizing that I had in there to place it above the comment section. So let’s try this – go to Genesis Simple Hooks, remove it from where you added it and then locate this box – genesis_after_post_content and place the code there. Let’s see what happens.


    Let me help you customize your theme, responsive header, Buddypress, Agentpress or technical issue!
    Visit me here: Cre8tiveDiva.com | Tweet Me! | Plus Me!
    When asking for help, please provide a link or screen shot showing your problem!

    #18370

    benconnor
    Participant
    Post count: 26

    Bummer,

    No luck I’m afraid.

    Did i need to tick the box for this:

    Unhook genesis_post_meta() function from this hook?

    Should I try the genesis_post_content box instead?

    Ben

    #18371

    anitac
    Participant
    Post count: 6407

    You did go back and remove those two lines right? Make sure you remove those. If you aren’t married to the share buttons being at the bottom – remove that one line of code and place it in the genesis_before_post_content and they will appear at the top under the Title & Meta.


    Let me help you customize your theme, responsive header, Buddypress, Agentpress or technical issue!
    Visit me here: Cre8tiveDiva.com | Tweet Me! | Plus Me!
    When asking for help, please provide a link or screen shot showing your problem!

    #18403

    David Decker
    Moderator
    Post count: 93

    Hi there!

    The “issue” here is – I wouldn’t say it’s an issue since it’s regular WordPress & Genesis behavior – that plugins just hook into “the_content” action hook, WordPress provides and place in their stuff. If you use this with lots of plugins things can go out of control, i.e. the get stuffed at the end of your content section or anywhere in between…

    To achieve what you want – if I understood correctly – is, to place anything for sharing etc. but after the in-page pagination links, right?

    I’ve just tested this myself with some custom HTML code in combination with a Genesis hook, and worked like a charm for me :)
    Here’s my code snippet:

    https://gist.github.com/deckerweb/4721359

    You should place this in your child theme’s functions.php — at the bottom, and without the opening “< ? php"!

    As is it does nothing, as I commented out the two examples for custom content: remove the 2 slashes to un-comment and use either line of them. The first line with "echo" is for placing HTML code, for example from external services. The second "echo" line is echoing a function, for example from a plugin. You have to change both appearances of "function_name_here" to the actual template function from the plugin. And also uncomment the 2 slashes before the "echo".

    I'd suggest to NOT use "Simple Hooks" plugin here, as in Simple Hooks no priority could be set up.
    With my function, you can change the priority at any time, if needed, like so:
    add_action( 'genesis_post_content', 'ddw_custom_content_after_pagination', 11 );
    —> lower priority
    add_action( 'genesis_post_content', 'ddw_custom_content_after_pagination', 9 );
    —> higher priority

    Before you use this way here, make a BACKUP of your functions.php file! Also, make sure that no other code snippets in Simple Hooks are placed in “genesis_post_content” hook. If so, please make a backup of them and remove them before continuing.

    Hope that helps, Dave :)


Viewing 15 posts - 1 through 15 (of 19 total)

You must be logged in to reply to this topic.