My blog archive featured image hover is gone :(

Community Forums Forums Design Tips and Tricks My blog archive featured image hover is gone :(

This topic is: not resolved

This topic contains 2 replies, has 2 voices, and was last updated by  joycegrace 1 year, 9 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #25543

    joycegrace
    Participant
    Post count: 58

    Hi, I had a hover state on my blog archives here: http://www.rebeccasehn.com/category/classic/

    You can even see the hover state image in the CSS if you look up #content-sidebar-wrap #content .post .bg-background-hover in Firebug or Chrome or whatever.

    What’s driving me crazy is that its now gone! I don’t know why. But I think it happened after we updated to the latest version of WordPress and Genesis.

    I feel like it’s starring me right in the face and I can’t figure out why it’s not working. I’ve tried applying the style to just .post-image and other things, but the closest I can get is the hover image appearing behind the featured image, not infront of it, even if I apply a z-index. It’s so weird.

    Any help would be so greatly appreciated, even if there is another way to get hover states on blog archive featured images other than what was done before on this site.

    This site is based on Scribble, if that helps.

    Thanks!

    P.S. If you look at the home page under “work” http://www.rebeccasehn.com/#work the hover state appears on those featured page images. I don’t know why it won’t appear on the blog archive images.


    Find me at Joyce Grace (http://www.joycegrace.ca) and Clicks Online Marketing (clicksonlinemarketing.com).

    #25710

    David Chu
    Participant
    Post count: 1428

    Hi Joyce,

    That’s a very nice site, and an interesting problem.  I do see the code you were looking at.  I would say that the basic reason the hover doesn’t work is simple.  The cause, somewhat less so.

    Essentially, on that page the hover doesn’t show the background because there’s no HTML that has the class of “bg-background-hover” that I can see.  You do have some Javascript errors, and I wonder if some jQuery from a plugin may have been providing that class before your upgrade broke it?   You could look and see if any jQuery-related plugins have an update.  That’s my best guess.

    If some plugin is shot, one could code some jQuery to make that happen again.  It would take some programming, maybe not too bad.   One could also do it with CSS with some finagling.  It’s possible that some custom CSS may have gotten torched by the upgrade, too.

    Dave


    Dave Chu · Custom WordPress Developer – likes collaborating with Designers

    #25730

    joycegrace
    Participant
    Post count: 58

    Yes I think you are right. We had some javascript issues that we tried to resolve recently and maybe that’s when we lost that class or html. I will look into it more. thanks!


    Find me at Joyce Grace (http://www.joycegrace.ca) and Clicks Online Marketing (clicksonlinemarketing.com).

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.