My Side bar won't stay on the left on my homepage

Community Forums Forums Design Tips and Tricks My Side bar won't stay on the left on my homepage

This topic is: resolved

This topic contains 4 replies, has 2 voices, and was last updated by  eatingonadime 9 months, 3 weeks ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #82308

    eatingonadime
    Member
    Post count: 3

    Hi, I just installed the magaine pro theme on my site and I selected to have the side bar on the left. However, it keeps going to the right on my homepage instead of the left. However, on all the other pages it is on the left like I want it. My site is http://www.eatingonadime.com

    Anyone have any ideas? Thanks!

    http://eatingonadime.com
    #82313

    nutsandbolts
    Moderator
    Post count: 3166

    Look in your front-page.php and remove the following:

    // Force content-sidebar layout setting
    		add_filter( 'genesis_pre_get_option_site_layout', '__genesis_return_content_sidebar' );

    It’s forcing the homepage to have a content/sidebar layout instead of honoring the sidebar/content layout you’ve set.


    Andrea Whitmer, Owner, Nuts and Bolts Media
    I provide dev and training services for web designers • Find me on Twitter and Google+

    #82347

    eatingonadime
    Member
    Post count: 3

    HI, my front page php has this

    // Force content-sidebar layout setting
    add_filter( ‘genesis_site_layout’, ‘__genesis_return_content_sidebar’ );

    any thoughts , this is magazine pro theme,

    #82348

    nutsandbolts
    Moderator
    Post count: 3166

    Right, that’s the same function. Remove those two lines and your homepage should display the correct layout.


    Andrea Whitmer, Owner, Nuts and Bolts Media
    I provide dev and training services for web designers • Find me on Twitter and Google+

    #82349

    eatingonadime
    Member
    Post count: 3

    great , thanks , appears to have solved the problem

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.