Nav Drop-Down Problems (BeeCrafty Theme)

Community Forums Forums Design Tips and Tricks Nav Drop-Down Problems (BeeCrafty Theme)

This topic is: resolved

This topic contains 2 replies, has 2 voices, and was last updated by  SingDancePlayLearn 1 year, 6 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #22110

    SingDancePlayLearn
    Participant
    Post count: 3

    Hi there,

    I’ve set up in the primary navigation menu a series of pages, that I’d like to be able to select from.  I’m using the BeeCrafty theme and the most recent version of Genesis framework and don’t believe I have any plugins that touch the navigation bar (though I have the search bar on the right of the nav bar, from Genesis’ built in options).   I’m using fancy drop-down but it’s even worse when I deselect that… anyway…

    What happens is I hover over or click the menu item and the drop-down shows up, but when I move the mouse cursor down to select one of the sub-menus, the drop-down goes away… sometimes.  I think it depends on how quickly I move the mouse, and/or where it lands, and/or if i leave it there afterwards.  It’s weird and inconsistent and very frustrating from a user experience perspective.

    My guess is that it may be a styling thing, that there’s a few pixels of gap between the menu and the drop-down, so when my mouse goes over it it loses the menu… or something.

    Has anyone experienced this before?  Unfortunately the site is not live yet, it’s just a coming soon page so I can’t show it… but I’m happy to elaborate, paste code, or even set up an account for you…  whatever, to get some help!

    Thanks,

    Chris

    webmaster@SingDancePlayLearn.com

    #22178

    Sridhar Katakam
    Participant
    Post count: 1005

    In theme’s style.css, comment out or delete

    [css]
    #nav li ul {
    margin: 2px 0 0 0;
    }
    [/css]


    #22233

    SingDancePlayLearn
    Participant
    Post count: 3

    Thank you, Sridhar!

     

    I ended up getting very prompt support from CopyBlogger proper.

    Turns out I had to remove the margin from the above styling, and ALSO had to remove the margin from the below styling:

    #nav .current_page_item ul {
    margin-top: 0px !important; <<– This was at 3px before
    overflow: hidden;
    }

    Closing out the issue.  Really happy with the support!

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.