Need urgent help please – dropdown menu going behind content on home page

Community Forums Forums Design Tips and Tricks Need urgent help please – dropdown menu going behind content on home page

This topic is: resolved

This topic contains 2 replies, has 2 voices, and was last updated by  leannemorrison 1 year, 7 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #3131

    leannemorrison
    Participant
    Post count: 21

    Hi, I hope someone can help me please!!  This is really urgent as the client is waiting on this to be sorted before he will approve site.

    I am using Genesis + Production theme (not supported by Studiopress now).  My client wanted a single video on the home page top.  The Genesis Media Project unfortunately did not fit the bill as he only has one video (the dropdown menu floated over this fine).  Therefore I have used a text widget in the home page top and inserted Youtube embed code.  Unfortunately the dropdown menu now drops behind the video.

    I have a test site set up at http://clientsites.jonmorrison.com.au

    I am not good at CSS, so would REALLY appreciate it if someone could tell me how I can force the dropdown menus to go OVER the top of the video.

    Alternatively if you can suggest another way of displaying his feature video in the home top widget I would love to hear from you.  Or even another Studiopress theme I could customise ….

    Many thanks in advance

    #3149

    derivative
    Participant

    Appears to work on OS X in Chome FF and Safari. What OS and browser? Typically you’d want to set a z-index to a number like 9999px; to have menu appear over other elements.

    #3150

    leannemorrison
    Participant
    Post count: 21

    thanks for your reply – very much appreciated.  I have been researching the issue flat out and found that the issue seems to be with the Youtube embeds in iframes specifically.  The instructions are here if anyone is interested http://www.electrictoolbox.com/float-div-youtube-iframe/.  Fortunately I think I managed to fix it myself  just now (which is pretty amazing in itself!), which is probably why an hour after I posted the distress call that you can see it working properly.

    Kind regards

    Leanne

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.