New Widget Areas

Community Forums Forums Design Tips and Tricks New Widget Areas

This topic is: not resolved

This topic contains 8 replies, has 3 voices, and was last updated by  keylimedigitaldesigns@gmail.com 1 year, 7 months ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #3414

    keylimedigitaldesigns@gmail.com
    Participant
    Post count: 28

    So I have a new question…
    > I am trying to get 6 widgets aligned like this site…
    http://www.keeperofthehome.org/
    >
    > I am using the blissful theme. I tried adding 3 new widget areas. I registered them using this code…. {which I borrowed from the inspired theme}
    >
    > /** Register widget areas */
    > genesis_register_sidebar( array(
    > ‘id’ => ‘home-middle-1′,
    > ‘name’ => __( ‘Home Middle #1′, ‘blissful’ ),
    > ‘description’ => __( ‘This is the first column of the home middle section.’, ‘blissful’ ),
    > ) );
    > genesis_register_sidebar( array(
    > ‘id’ => ‘home-middle-2′,
    > ‘name’ => __( ‘Home Middle #2′, ‘blissful’ ),
    > ‘description’ => __( ‘This is the second column of the home middle section.’, ‘blissful’ ),
    > ) );
    > genesis_register_sidebar( array(
    > ‘id’ => ‘home-middle-3′,
    > ‘name’ => __( ‘Home Middle #3′, ‘blissful’ ),
    > ‘description’ => __( ‘This is the third column of the home middle section.’, ‘blissful’ ),
    > ) );
    >
    > and then using this css…
    >
    > /* Home Middle
    > ———————————————————— */
    >
    > .home-middle {
    > margin: 0 auto;
    > overflow: hidden;
    > padding: 25px 25px 5px;
    > width: 910px;
    > }
    >
    > .home-middle-1 {
    > float: left;
    > margin: 0 24px 0 0;
    > width: 287px;
    > }
    >
    > .home-middle-2 {
    > float: left;
    > width: 287px;
    > }
    >
    > .home-middle-3 {
    > float: right;
    > width: 287px;
    > }
    > But now nothing is showing up???
    > What am I doing wrong?
    >
    > URL
    http://www.client.keylimedigitaldesigns.com/

    #3426

    anitac
    Participant
    Post count: 7040

    You still need to add their respective placement in the home.php file.


    Let me help you customize your theme, responsive header, Buddypress, Agentpress or technical issue!
    Visit me here: Cre8tiveDiva.com | Tweet Me! | Plus Me!
    When asking for help, please provide a link or screen shot showing your problem!

    #3673

    keylimedigitaldesigns@gmail.com
    Participant
    Post count: 28

    Okay so now I got the 3 new widget areas to show up but I can’t figure out how to make them align horizontally. I added float: left; to them but still can’t figure it out….

    Here is what is in my css..

    /* Home Middle
    ———————————————————— */
    .home-middle {
    margin: 0 auto;
    overflow: hidden;
    padding: 25px 25px 5px;
    width: 570px;
    }
    .home-middle-1 {
    float: left;
    margin: 0 24px 0 0;
    width: 120px;
    }

    .home-middle-2 {
    float: left;
    width: 120px;
    }

    .home-middle-3 {
    float: left;
    width: 120px;
    }

    #3686

    anitac
    Participant
    Post count: 7040

    The last one should be RIGHT. And then the should line up.


    Let me help you customize your theme, responsive header, Buddypress, Agentpress or technical issue!
    Visit me here: Cre8tiveDiva.com | Tweet Me! | Plus Me!
    When asking for help, please provide a link or screen shot showing your problem!

    #3692

    anitac
    Participant
    Post count: 7040

    You don’t have the 3 widgets in the Home.php file – at least from my computer you don’t. You need to have the HOME MIDDLE coded into the home.php.


    Let me help you customize your theme, responsive header, Buddypress, Agentpress or technical issue!
    Visit me here: Cre8tiveDiva.com | Tweet Me! | Plus Me!
    When asking for help, please provide a link or screen shot showing your problem!

    #3795

    keylimedigitaldesigns@gmail.com
    Participant
    Post count: 28

    Thanks so much for helping me figure this out. I changed the last one in the css to float: right; and still not lining up horizontal….

    Okay so here is the css I have…

    /* Home Middle
    ———————————————————— */
    .home-middle {
    margin: 0 auto;
    overflow: hidden;
    padding: 25px 25px 5px;
    width: 570px;
    }
    .home-middle-1 {
    float: left;
    margin: 0 24px 0 0;
    width: 120px;
    }

    .home-middle-2 {
    float: left;
    width: 120px;
    }

    .home-middle-3 {
    float: right;
    width: 120px;
    }

     

    Here is the home.php I have…

    /** Add home middle 1 widget area */
    add_action( ‘genesis_before_loop’, ‘blissful_home_middle_1′ );
    function blissful_home_middle_1() {
    dynamic_sidebar( ‘home-middle-1′ );
    }

    /** Add home middle 2 widget area */
    add_action( ‘genesis_before_loop’, ‘blissful_home_middle_2′ );
    function blissful_home_middle_2() {
    dynamic_sidebar( ‘home-middle-2′ );
    }

    /** Add home middle 3 widget area */
    add_action( ‘genesis_before_loop’, ‘blissful_home_middle_3′ );
    function blissful_home_middle_3() {
    dynamic_sidebar( ‘home-middle-3′ );
    }

    and here is the functions php I have…

    /** Register widget areas */
    genesis_register_sidebar( array(
    ‘id’ => ‘home-middle-1′,
    ‘name’ => __( ‘Home Middle #1′, ‘blissful’ ),
    ‘description’ => __( ‘This is the first column of the home middle section.’, ‘blissful’ ),
    ) );
    genesis_register_sidebar( array(
    ‘id’ => ‘home-middle-2′,
    ‘name’ => __( ‘Home Middle #2′, ‘blissful’ ),
    ‘description’ => __( ‘This is the second column of the home middle section.’, ‘blissful’ ),
    ) );
    genesis_register_sidebar( array(
    ‘id’ => ‘home-middle-3′,
    ‘name’ => __( ‘Home Middle #3′, ‘blissful’ ),
    ‘description’ => __( ‘This is the third column of the home middle section.’, ‘blissful’ ),
    ) );

     

    #3798

    anitac
    Participant
    Post count: 7040

    Check your Gmail. I sent you a message.


    Let me help you customize your theme, responsive header, Buddypress, Agentpress or technical issue!
    Visit me here: Cre8tiveDiva.com | Tweet Me! | Plus Me!
    When asking for help, please provide a link or screen shot showing your problem!

    #5507

    lizbarber05
    Participant
    Post count: 1

    Hi I’m trying to figure this out too.  Were there any specific changes to the coding above you made to get everything to work for you?

    Thanks!

    -Liz

    #5508

    keylimedigitaldesigns@gmail.com
    Participant
    Post count: 28

    I couldn’t ever get it figured out. At least not with the Blissful theme. So I switched to the adorable theme and made it work! :) And John was really helpful and helped me make a few tweaks. It is on another forum post right here > http://www.studiopress.com/forums/topic/aligning-widgets/#post-4972

    Kendra

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.