Odd Portfolio Display Issue in Modern Portfolio Pro theme

Community Forums Forums Design Tips and Tricks Odd Portfolio Display Issue in Modern Portfolio Pro theme

This topic is: resolved

This topic contains 7 replies, has 3 voices, and was last updated by  AC 11 months ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #81439

    dsignor
    Participant
    Post count: 6

    I have been using Modern Portfolio on two sites (and adore it); I tried last night switching to Modern Portfolio Pro, on the lesser-trafficked of the two sites, and am running into an odd display problem on the front page. I display six recent posts’ featured images, which appear three across, two rows.

    Now, the third image in each row is bumped to the next line: http://archives.manyfaceted.com/

    I have not touched the CSS, all I did was upload the new theme and activate it. I have set up the Featured Posts widget exactly as instructed here, except that I don’t display the post title, but the margins on the posts aren’t allowing for three-across display. (I am on Mac OS X, using the latest Firefox, if that helps.)

    Has anyone else experienced this, or have a fix?

    Thanks a bunch!
    – Danielle

    • This topic was modified 11 months ago by  dsignor.
    • This topic was modified 11 months ago by  dsignor.
    http://archives.manyfaceted.com/
    #81444

    AC
    Blocked
    Post count: 7712

    I used Firebug and got it to work. Look for this:

    .mpp-home .content .featuredpost .entry, #services .alignright {
        float: left;
        margin-right: 4.26316%;
        width: 29.8246%;
    }

    Change the margin-right to:

    margin-right: 2.26316%;

    Save and let me know if it worked.

    #81447

    dsignor
    Participant
    Post count: 6

    That fixed it! Still not clear on why the demo theme works fine, but my install did not, when it hadn’t been edited or customized, but at least I’ve got my columns back.

    Thanks for your help!

    #81448

    AC
    Blocked
    Post count: 7712

    You’re welcome.

    #81515

    Just Me
    Participant
    Post count: 23

    I am having the same problem on this site, but my CSS margin measurements are different. Can you take a look?

    Site with a problem

    Screenshot of problem


    #81558

    AC
    Blocked
    Post count: 7712

    That is happening because the first image has “two line” entries. The #1 has dropped off. So look for this:

    .featured-content .entry-title {
        border: medium none;
        font-size: 1.8rem;
        line-height: 1.2;
        margin-bottom: 0.8rem;
        min-height: 300px;
    }

    Add the min-height: 300px line to your code which you don’t have. If it happens again – just re-adjust the px to a larger number.

    #81731

    Just Me
    Participant
    Post count: 23

    Problem solved. You are awesome!


    #81732

    AC
    Blocked
    Post count: 7712

    Thanks and you’re welcome! Happy Holidays.

Viewing 8 posts - 1 through 8 (of 8 total)

The topic ‘Odd Portfolio Display Issue in Modern Portfolio Pro theme’ is closed to new replies.