P not H1 in Header

Community Forums Forums General Discussion P not H1 in Header

This topic is: not resolved

Tagged: ,

This topic contains 8 replies, has 3 voices, and was last updated by  weslinda 2 years, 3 months ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #38988

    weslinda
    Participant

    So I built a custom theme for a client, and the question came back about H1’s on the page. It’s a custom design, but I’m curious as to why the title of the page is showing up in the header in a P instead of H1 like I’m accustomed to with Genesis.

    Anyone have any ideas why this might be happening?


    Loving the Genesis Life!

    http://www.tylliebarbosa.com/
    #38989

    cdils
    Participant

    Can you post a link? Also which pages (all pages?) is it happening on? Wondering if there’s a DIV that didn’t get closed out?


    Have you been helped in this forum? Pay it forward and answer someone else’s question. I bet you’ll know the answer to at least one question. :)

    I host a weekly WordPress-focused podcast called Office Hours. I tweet @cdils.

    • This reply was modified 2 years, 3 months ago by  cdils.
    • This reply was modified 2 years, 3 months ago by  cdils.
    #38993

    weslinda
    Participant

    I was wondering if that was going to be confusing. I did add a link (www.tylliebarbosa.com) but it’s not obvious that it’s the URL of the post. I added it in the new URL field that is a part of the new post form. ¬†This should be above my signature and have a title with it so folks know it’s connected to the post.

    It’s across the site. All pages and posts use P instead of H1 for the SEO title.


    Loving the Genesis Life!

    • This reply was modified 2 years, 3 months ago by  weslinda.
    • This reply was modified 2 years, 3 months ago by  weslinda.
    #38995

    cdils
    Participant

    Ah! Okay, that’s actually perfectly normal behavior.

    H1’s are reserved for individual page/post titles. The site title’s supposed to be in a paragraph tag. :)


    Have you been helped in this forum? Pay it forward and answer someone else’s question. I bet you’ll know the answer to at least one question. :)

    I host a weekly WordPress-focused podcast called Office Hours. I tweet @cdils.

    #38996

    weslinda
    Participant

    That’s not my experience. I haven’t gone through everyone, but every other Genesis site I’ve pulled uses H1 there, not P. ¬†Across the board. I’m not sure why it would do that in THAT setup, and not the others.


    Loving the Genesis Life!

    #39003

    cdils
    Participant

    Now that I think about it…maybe the difference is when using theme support for a custom header, like

    add_theme_support( ‘genesis-custom-header’…..

    I could be making stuff up. But I swear I’ve seen that P in some themes.


    Have you been helped in this forum? Pay it forward and answer someone else’s question. I bet you’ll know the answer to at least one question. :)

    I host a weekly WordPress-focused podcast called Office Hours. I tweet @cdils.

    #39004

    weslinda
    Participant

    Never mind, just ignore me, I live and breathe stupidity.


    Loving the Genesis Life!

    #39006

    Ozzy
    Participant

    i’m seeing posts that have an h1. the only page with a title i saw was the contact page. can you add a link to a page or post where you see this happening?

    nevermind… you must have figured it out!


    • This reply was modified 2 years, 3 months ago by  Ozzy. Reason: fix problem as i was writing
    • This reply was modified 2 years, 3 months ago by  Ozzy. Reason: fix problem as i was writing
    #39011

    weslinda
    Participant

    I didn’t “figure” it out, I ended up making a quick function to make the site do it like I wanted it to. Replaced built in function with custom one.


    Loving the Genesis Life!

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.