Page Title in Minimum Pro not showing!

Community Forums Forums Design Tips and Tricks Page Title in Minimum Pro not showing!

This topic is: resolved

This topic contains 3 replies, has 2 voices, and was last updated by  asbilly92 1 year, 6 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #104281


    I can not get my page title to display in the browser tab!

    I’m using the Genesis MInimum Pro theme and I’ve never had this problem before with this theme…I’ve added the page title in the Genesis, SEO settings and yet when I check, and even refresh it is still just shows the web address for the site..?

    Eiew bad for my seo! Any help would be appreciated!!


    Probably a silly question, but have you entered a site title in Settings > General? I see that your posts are displaying the title correctly, so it appears to be a problem on the homepage only.

    Andrea Whitmer, Owner/Developer, Nuts and Bolts Media
    I provide development and training services for designers • Find me on Twitter and Google+



    NO not a silly question at all!!

    YES there is a title in settings > general….there is also the same exact title in the Genesis SEO title area….I have other sites running this same genesis chile theme and the home page titles are set up exactly the same way and the title shows up great……

    Thank u for taking the time to help



    Just an update! I got this fixed! For other’s or whom else this might help… I had my Reading > Settings kind of done wrong even though the site ‘looked’ like it was fine.

    I wanted the site to come up to the Genesis blog Archive excerpts page, not the typical front-page.php like most folks that use the Minimum Pro theme! I had to rename my front-page.php file to front-page.txt and then go back into my settings and choose ‘Your Latest Posts’ as the Front Page Display. Doing this fixed my issue with the Page Title not showing!

    Thanks to any whom helped ;-)

Viewing 4 posts - 1 through 4 (of 4 total)

The topic ‘Page Title in Minimum Pro not showing!’ is closed to new replies.