Passing query in url Associate theme

Community Forums Forums General Discussion Passing query in url Associate theme

This topic is: resolved

This topic contains 2 replies, has 2 voices, and was last updated by  David Chu 4 months, 2 weeks ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #98091

    Dzynit
    Member
    Post count: 1

    I’ve narrowed this down to where I’m pretty sure it’s theme related. First, I was trying to pass form variables using the gravity form plugin (which normally works fine). But as soon as the ? is added to the end of the url, the page does not redirect correctly – it continues to go to a 404 error page.
    I thought at first there was an issue with gravity forms, but when I tried the normal wordpress search which adds ?s=mysearchterm, the same thing happens.
    I deactivated all plugins and the issue remains. I’m positive there aren’t any redirects set up anywhere. And the same issue is on two different hosts, so it’s not the hosting server either.

    Has anyone else had this same issue and been able to get it resolved?

    Thanks for any help.

    • This topic was modified 4 months, 2 weeks ago by  Susan. Reason: This is not a forum bug or suggestion
    • This topic was modified 4 months, 2 weeks ago by  Susan. Reason: This is not a forum bug or suggestion
    http://injurylaworegon.com/
    #98448

    Dzynit
    Member
    Post count: 1

    The problem turned out to be that you can’t use “name” as a variable name in the query part of the url. It acted similar to performing a search.

    The wordpress search will work when done from the homepage only, which could be related to the use of .htm on our url’s. So this isn’t a problem because we’re not using a search box on the site. If we add one, I can adjust the search form action accordingly so it works correctly.

    #98449

    David Chu
    Participant
    Post count: 1347

    Hi,
    It’s hard to see exactly from the outside, but I see a very big suspect: the permalinks. You’re adding “.htm” as a suffix, possibly to preserve SEO from an older site.

    I just did a quick test adding .htm to permalinks, and it worked great, including search. That only works for Posts, however, and you’re doing something special to make the pages do .htm permalinks. I would have suspected Yoast, which as cool as it is, does crazy complicated processing, but you had tried disabling all plugins.

    Hard to say, but I have one last idea for what could be a research project… even if you disable all plugins, some discourteous plugins may leave their code in your .htaccess file, including stuff playing with your links.

    Good luck,
    D


    Dave Chu · Custom WordPress Developer – likes collaborating with Designers

Viewing 3 posts - 1 through 3 (of 3 total)

The topic ‘Passing query in url Associate theme’ is closed to new replies.