permalinks give 404 error when anything other than default setting

Community Forums Forums Design Tips and Tricks permalinks give 404 error when anything other than default setting

This topic is: not resolved

This topic contains 7 replies, has 3 voices, and was last updated by  riryrery 7 months, 3 weeks ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #94824

    riryrery
    Participant
    Post count: 20

    Hi, on this site: http://www.amblesideonline.org/studio
    I’m running WP 3.8.1 with Associate Child Theme and Search Engines Discouraged.

    The forum navigation works fine when it’s default permalinks, but when I switch it to Post Name, I get a 404 error on all pages except the home page.

    I think it has something to do with the wrong directory? Maybe my files are located in the wrong place?

    All my pages are showing permalinks in this location: http://www.amblesideonline.org/studio/

    I checked with my server to make sure mod_rewrite is enabled on our server.

    Any help would be appreciated. Thank you

    • This topic was modified 8 months, 1 week ago by  Susan. Reason: This is not a forum bug or suggestion
    • This topic was modified 8 months, 1 week ago by  Susan. Reason: This is not a forum bug or suggestion
    http://www.amblesideonline.org/studio/
    #94826

    riryrery
    Participant
    Post count: 20

    FYI – the only plugins I’ve added are Genesis Simple Edits and Simple Social Icons

    #95266

    riryrery
    Participant
    Post count: 20

    It has been more than 2 days, should I post this topic somewhere else to get a response?

    #96138

    riryrery
    Participant
    Post count: 20

    Anyone?

    #96139

    riryrery
    Participant
    Post count: 20

    Susan,
    I saw this at the bottom of my initial post:
    This topic was modified 5 days, 16 hours ago by Susan. Reason: This is not a forum bug or suggestion
    This topic was modified 5 days, 16 hours ago by Susan. Reason: This is not a forum bug or suggestion

    http://www.amblesideonline.org/studio/

    Is this not the right place to post this question? Where would I post it to find support to get the Associate Theme postname permalinks to work?

    #96181

    Summer
    Participant
    Post count: 1122

    I think Susan’s message means you had put this post in the “Forum Bugs” forum instead of either “General Discussion” or “Design Tips”… most of the other forum mods & contributors would never have seen your question in order to try to help.

    That said, your site seems to be installed in the /studio subdirectory, so changing permalinks to post name should work. Is your .htaccess set up correctly? Is there any custom coding that could also be interfering?


    #96190

    Andrea Rennick
    Keymaster
    Post count: 1351

    Permalinks are not theme based.

    See: http://codex.wordpress.org/Permalinks

    If you have issues setting up permalinks, talk to your web host.


    **forum signature**
    If you need technical support for your theme please file a ticket.

    The forums are community based. Staff only monitors the forum for issues relating to the forum itself and to redirect users to where they need to go.

    Twitterholic

    #97574

    riryrery
    Participant
    Post count: 20

    This is what my host told me.

    “I would suggest speaking with a web developer. The server is set up for url rewrites it just needs to be told what to do with the correct web coding.”

    This is the whole of what is in my .htaccess file right now:

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /studio/
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /studio/index.php [L]
    </IfModule>

    I removed the “.txt” at the end of the filename. It is located in my http://www.amblesideonline.org/studio/ file

    It is set to CHMOD 0644

    My host insists the server is set up for url rewrites.

    When I select Postname permalink structure – I still get this error:

    If your .htaccess file were writable, we could do this automatically, but it isn’t so these are the mod_rewrite rules you should have in your .htaccess file. Click in the field and press CTRL + a to select all.

    What am I missing?

    • This reply was modified 7 months, 3 weeks ago by  riryrery.
    • This reply was modified 7 months, 3 weeks ago by  riryrery.
Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.