Post Formats Not Working

Community Forums Forums Design Tips and Tricks Post Formats Not Working

This topic is: not resolved

Tagged: 

This topic contains 15 replies, has 3 voices, and was last updated by  pamela631 1 year, 9 months ago.

Viewing 15 posts - 1 through 15 (of 16 total)
  • Author
    Posts
  • #3277

    pamela631
    Participant
    Post count: 2

    I’m working with the Lifestyle Theme.. I’ve already finished a blog just fine with the post formats and now I’m working on a new blog, I changed the code in functions.php by copy and paste via the read me file instructions, the post formats are in the correct images folder, but they are not working..  can someone help me?  Here is the site I’m working on..   Right under the sticky post sample are a couple of post format “posts”..  you’ll see they are not working right..  Thanks for any help with this.

    http://preview.theposhbox.net/client1/?page_id=24

    #3281

    AC
    Blocked
    Post count: 7712

    Not sure if this will help – but in the information you copied/pasted – make sure you have referenced the correct theme name. Sometimes that throw things off. But I’m not sure.

    #3284

    pamela631
    Participant
    Post count: 2

    No, I don’t think so because the theme name isn’t in that function code.

    I changed this:

    /** Add support for post formats */
    // add_theme_support( ‘post-formats’, array( ‘aside’, ‘audio’, ‘chat’, ‘gallery’, ‘image’, ‘link’, ‘quote’, ‘status’, ‘video’ ) );
    // add_theme_support( ‘genesis-post-format-images’ );

    To this:

    /** Add support for post formats */
    add_theme_support( ‘post-formats’, array( ‘aside’, ‘audio’, ‘chat’, ‘gallery’, ‘image’, ‘link’, ‘quote’, ‘status’, ‘video’ ) );
    add_theme_support( ‘genesis-post-format-images’ );

     

     

     

    #3293

    AC
    Blocked
    Post count: 7712

    So you removed the // from the beginning of the second and last lines and it doesn’t work. Did you try adding the // back on those lines?

    • This reply was modified 1 year, 9 months ago by  AC.
    • This reply was modified 1 year, 9 months ago by  AC.
    #3303

    pamela631
    Participant
    Post count: 2

    Yes, because that actually ADDS the Post Format options back into the post posting area.. otherwise, post format is not an option when creating a post..  when I take those out, it is an option when creating a post..  Here are the instructions:

    To utilize the post format functionality of WordPress and the Lifestyle theme, you will need to go into the Lifestyle child theme functions.php file and change this code:

    /** Add support for post formats */
    // add_theme_support( ‘post-formats’, array( ‘aside’, ‘audio’, ‘chat’, ‘gallery’, ‘image’, ‘link’, ‘quote’, ‘status’, ‘video’ ) );
    // add_theme_support( ‘genesis-post-format-images’ );

    To this:

    /** Add support for post formats */
    add_theme_support( ‘post-formats’, array( ‘aside’, ‘audio’, ‘chat’, ‘gallery’, ‘image’, ‘link’, ‘quote’, ‘status’, ‘video’ ) );
    add_theme_support( ‘genesis-post-format-images’ );

    So when I do this, it added the options to select which post format I want..  but the images are not shown..  that’s the problem..

    #3328

    AC
    Blocked
    Post count: 7712

    Are you using the same theme as your first blog? And did you style the CSS for that area?

    #3359

    pamela631
    Participant
    Post count: 2

    Yes, I’m using the exact same theme (Lifestyle), and I didn’t change anything in the CSS for that area…

    #3362

    AC
    Blocked
    Post count: 7712

    Wow. This may sound kinda dumb, but it’s worked for me in the past – copy and paste the code into Notepad – then check all your quotes and appostrophe’s, then copy it back in there. Sometimes it doesn’t copy over right. This happened to someone else on here last week.

    Oh, and can you share the link to the first blog so I can look at that one too – to compare them?

    #3363

    AC
    Blocked
    Post count: 7712

    On the old forum board, someone had this problem and Andrea wrote this:

    Edit the post. Click the image upload button. The image must be listed in the Gallery tab. Uploading an image while editing your post creates an association in the db whereby WP sees the image as “attached” to the post.

    #3378

    pamela631
    Participant
    Post count: 2

    Good Evening Anita..  First, I want to thank you for helping me..  I really appreciate it.

    Yes, I checked all of the ‘ and “..  everything is fine.

    Here is the blog that they work in, the direct page that they are on..  page 4 of that blog:  http://preview.theposhbox.net/threecol/?paged=4

    Then of course, the one I’m workin on now with the problem:  http://preview.theposhbox.net/client1/

    Now my question, especially in reading your second reply..  I have never wrote a post and used them, only in a sample and I thought they are supposed to automatically appear after choosing one of the formats, right?  I don’t have to embed them myself, right?   I’m hoping I’m not showing my blonde roots here, LOL

    Thanks for your help..

     

    #3381

    pamela631
    Participant
    Post count: 2

    So..  I just now added each of the icons to my gallery via media library..  still not working…

    #3382

    AC
    Blocked
    Post count: 7712

    Okay, so I believe you need to create a Post – then select the correct Post Format from the drop down on the right. Try creating a post.

    #3383

    pamela631
    Participant
    Post count: 2

    Yes, that is exactly what I have been doing..  I just did another one, choosing the “link” post format..  nothing…

    #3385

    AC
    Blocked
    Post count: 7712

    The URL’s are written differently – the one that works is “?paged=4″ – the one that doesn’t work is “?page_id=24″ – why is one “paged” and the other page_id? Maybe it’s your Permalinks. Try resetting your permalinks.

    #3394

    nickthegeek
    Keymaster
    Post count: 751

    Pamela,

    This is an issue with the blog page template and the post formate icon code. It will need to be fixed in Genesis. Look at your category page to see that the icons are working

    http://preview.theposhbox.net/client1/?cat=1

Viewing 15 posts - 1 through 15 (of 16 total)

You must be logged in to reply to this topic.