Problem with Custom Header Size in Agency Pro

Community Forums Forums Design Tips and Tricks Problem with Custom Header Size in Agency Pro

This topic is: not resolved

This topic contains 4 replies, has 2 voices, and was last updated by  LaurelR 6 months, 1 week ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #96169

    LaurelR
    Member
    Post count: 4

    I’ve changed the size of the header in Agency Pro to be 960 x 365 in my css and functions.php, but it’s not covering both my primary and secondary menu bars (http://bigsistersummit.com). How do I fix this? Appreciate any insights.

    • This topic was modified 6 months, 1 week ago by  LaurelR.
    • This topic was modified 6 months, 1 week ago by  LaurelR.
    http://bigsistersummit.com
    #96177

    stinkykong
    Participant
    Post count: 165

    .site-header by default in Agency Pro is given the rule

    position: fixed;

    which keeps the header section (with the widgeted menu in the demo) always visible at the top and covering content underneath it. So increasing the height of it will either have to be compensated in one or two (or more?) ways.

    Give it a rule changing the position from fixed to static or relative

    position:static;
    or
    position:relative;

    Put a rule back in (I believe your removed this…not for sure) giving top padding to .site-container

    .site-container { padding-top: 37rem;}

    However, the padding option may not work best on various screen sizes.

    Hope this helps.


    Web Design by Websentia Web Services
    http://websentia.com

    • This reply was modified 6 months, 1 week ago by  stinkykong.
    • This reply was modified 6 months, 1 week ago by  stinkykong.
    #96196

    LaurelR
    Member
    Post count: 4

    Thank you for the explanation @stinkykong. I changed the code as you suggested, but it didn’t change anything on my site.

    #96208

    stinkykong
    Participant
    Post count: 165

    I think it actually did, Laurel. I can see the changes.

    I’m willing to bet that your browser or ISP caching is preventing the change from showing for you.

    See this screenshot at

    http://websentia.com/documents/exampleScreenshots/Screen%20Shot%202014-03-23%20at%201.42.06%20PM.png

    You’ll see that using both suggestions went overboard. I’d remove the padding rule first and check it on various screen sizes but you’d have to get your cache cleared to see.

    Did you try your refresh button? Can you try another browser? Maybe an issue with your ISP.

    You could also check it at
    http://developers.google.com/speed/pagespeed/insights/?url=http%3A%2F%2Fbigsistersummit.com%2F&tab=desktop (small viewing window)
    or perhaps

    http://quirktools.com/screenfly/


    Web Design by Websentia Web Services
    http://websentia.com

    #96237

    LaurelR
    Member
    Post count: 4

    Hi Stinkykong,

    You’re right it did, thank you!!!! Cleared out my cache and saw what you saw. Changed the padding to 0 as you recommended and it’s working perfectly. Thank you SO much for your help. Really appreciate it!!!!!!

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.