Problem with Widget added to Luscious Theme – PHP or CSS issue?

Community Forums Forums Design Tips and Tricks Problem with Widget added to Luscious Theme – PHP or CSS issue?

This topic is: not resolved

This topic contains 10 replies, has 2 voices, and was last updated by  chantal2012 1 year, 4 months ago.

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #2444

    chantal2012
    Participant
    Post count: 53

    I submitted this through the help center and was advised to submit it in the forum.  I successfully added a widgeted area to my home page so I could use the Dynamic Content Gallery (I am using the Luscious theme).  I was wondering how to add a little bit more space between the bottom of the DCG and the top of the title of my first post.

    Also, when I click on one of the articles featured in the DCG and it takes me to the articles, the pics from the DCG are showing up all over the place and everything is messed up.  It’s kinda like the DCG was partly installed on post pages, not just the homepage.  Obviously I want it just on the homepage.  I am used to working with the Lifestyle theme and really like this feature.

    My site is http://www.auntieshauntie.com

    #2445

    anitac
    Participant
    Post count: 6383

    Look for this in your style.css and then add a bottom margin to it –     margin-bottom: 15px;

    .before-posts-sidebar {
    background: none repeat scroll 0 0 #DDDDDD;
    padding: 10px;

    }

     


    Let me help you customize your theme, responsive header, Buddypress, Agentpress or technical issue!
    Visit me here: Cre8tiveDiva.com | Tweet Me! | Plus Me!
    When asking for help, please provide a link or screen shot showing your problem!

    • This reply was modified 1 year, 4 months ago by  anitac.
    • This reply was modified 1 year, 4 months ago by  anitac.
    #2475

    chantal2012
    Participant
    Post count: 53

    Thanks anitac!  That solves my first problem…I still have an issue with my second problem.  It seems that the DCG that I installed on my first page is screwing up the rest of the site.  Does anyone know how to fix this?

    #2478

    anitac
    Participant
    Post count: 6383

    Did you add an image to the Featured Image for the Slider *and* did you add that same picture to the body? The slider is showing up on ALL pages. Can you copy and paste the code you used to get the slider in there?

    **Added** This is a very easy way to get the slider or other widget area on your home page only. Read this – http://www.briangardner.com/home-widget-area-eleven40/.


    Let me help you customize your theme, responsive header, Buddypress, Agentpress or technical issue!
    Visit me here: Cre8tiveDiva.com | Tweet Me! | Plus Me!
    When asking for help, please provide a link or screen shot showing your problem!

    • This reply was modified 1 year, 4 months ago by  anitac. Reason: to add a link at the bottom
    • This reply was modified 1 year, 4 months ago by  anitac. Reason: to add a link at the bottom
    #2483

    chantal2012
    Participant
    Post count: 53

    This is what I did exactly…I followed the tutorial that the help desk suggested http://designsbynickthegeek.com/tutorials/add-widgeted-sidebar for “Sidebar Before Posts”.  First I added the following code to my functions.php file:

    genesis_register_sidebar( array(
    ‘id’ => ‘before-posts-sidebar’,
    ‘name’ => ‘Before Posts’,
    ‘description’ => ‘This is a sidebar that goes before the posts in the #content.’, ) );

    Then I added the following code, once again to the functions.php file:

    add_action( ‘genesis_before_loop’, ‘child_before_posts_sidebar’ );
    /** Loads a new sidebar before the posts in the #content */
    function child_before_posts_sidebar() {
    echo ‘<div class=”before-posts-sidebar”>’;
    dynamic_sidebar( ‘before-posts-sidebar’ );
    echo ‘</div>’;
    }

    Then I added this code to my style.css sheet:

    /* Before Posts ———————————————————— */
    .before-posts-sidebar {
    background: #dddddd;
    padding: 10px;
    }

    I’m used to using the Lifestyle theme but really like the look of the Luscious Theme.  I just wanted to add this widgeted area to my homepage so I could add the DCG but obviously didn’t want to screw up the rest of the site.  I would appreciate any help. :)

    #2486

    anitac
    Participant
    Post count: 6383

    Where you put your second set of functions – I think you need to REPLACE it – here is Brian’s code (I modified to add your elements)

    ** Add the home featured section */
    add_action( ‘genesis_before_loop’, ‘child_before_posts_sidebar’ );
    function child_before_posts_sidebar() {

        /** Do nothing on page 2 or greater */
        if ( get_query_var( ‘paged’ ) >= 2 )
            return;

        genesis_widget_area( ‘before-posts-sidebar’, array(
        ‘before’ => ‘<div>’,
        ) );

    }

    I think it should look something like that.


    Let me help you customize your theme, responsive header, Buddypress, Agentpress or technical issue!
    Visit me here: Cre8tiveDiva.com | Tweet Me! | Plus Me!
    When asking for help, please provide a link or screen shot showing your problem!

    • This reply was modified 1 year, 4 months ago by  anitac.
    • This reply was modified 1 year, 4 months ago by  anitac.
    #2495

    chantal2012
    Participant
    Post count: 53

    Where did you get that code? Can you send me the link?

    #2496

    anitac
    Participant
    Post count: 6383

    I sent it above – a few messages up. Brian’s is a little easier – http://www.briangardner.com/home-widget-area-eleven40/.


    Let me help you customize your theme, responsive header, Buddypress, Agentpress or technical issue!
    Visit me here: Cre8tiveDiva.com | Tweet Me! | Plus Me!
    When asking for help, please provide a link or screen shot showing your problem!

    #2518

    chantal2012
    Participant
    Post count: 53

    That didn’t work :( . I will contact the help desk again.

    #2529

    anitac
    Participant
    Post count: 6383

    Okay, did you add to what you have or did you use Brian’s instead. Maybe if you go back and do it per Brian’s instructions you can get it to work. It works like a charm for me. Good luck.


    Let me help you customize your theme, responsive header, Buddypress, Agentpress or technical issue!
    Visit me here: Cre8tiveDiva.com | Tweet Me! | Plus Me!
    When asking for help, please provide a link or screen shot showing your problem!

    #2541

    chantal2012
    Participant
    Post count: 53

    I did try it per his instructions…hopefully someone else will chime in…thanks for your help! :)

Viewing 11 posts - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.