Problems with Pretty Young Thing Theme

Community Forums Forums Design Tips and Tricks Problems with Pretty Young Thing Theme

This topic is: not resolved

This topic contains 3 replies, has 2 voices, and was last updated by  David Chu 1 year, 1 month ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #60503

    thejellyjars
    Participant
    Post count: 1

    My site, http://www.thejellyjars.com seems to have a glitch in it that I can’t figure out: On the homepage, it shows all of my recent posts, and then when you you scroll to the bottom there is a “Next Page” link that should take me to the following posts that I have done. On the home page, when you scroll down and hit “Next Page” to get to more posts, it just refreshes that main page and shows those same initial posts, but what is weird is that next to our name and tagline, it then says Part 2 next to it and the URL reads .com/page/2/. It won’t allow clicking through to other posts.

    Why does the “Next Page” just refresh back to that homepage?

    There seems to be some sort of glitch with how the site seems to be interpreting our home page- it shows as our top post- not an actual post.

    Can somebody please help me with this? I’ve been advised that it might be a theme-specific problem and I would love to get it figured out! Thanks!

    http://www.thejellyjars.com
    #60514

    David Chu
    Participant
    Post count: 1373

    Hi,
    The paging thing is a standard WordPress theme feature if your loop grabs more Posts than the template is told to show per page. But it doesn’t always work for a variety of reasons.

    The short answer is, I don’t know without doing testing and being inside, but I do have one thing to look at.

    You have Super Cache. So I would try shutting the cache off and see if the paging begins to work. There is also a setting someplace in its admin that allows you to turn off the cache on selected pages, so you could experiment with that.

    Good luck,
    Dave


    Dave Chu · Custom WordPress Developer – likes collaborating with Designers

    #60703

    thejellyjars
    Participant
    Post count: 1

    Thanks for getting back to me, David. I don’t have too many plugins installed, but I did try deactivating all plugins (including Super Cache) to see if that resolved anything but the issue was still there. I’ll keep trying to figure it out.

    #60709

    David Chu
    Participant
    Post count: 1373

    Sure thing. That is a common problem with many themes. It’s possible that official support may have an idea or two, there may be some trick to it. I haven’t used that particular theme, so I don’t know its innards.

    Dave


    Dave Chu · Custom WordPress Developer – likes collaborating with Designers

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.