Question about JQuery on Scribble's home page

Community Forums Forums General Discussion Question about JQuery on Scribble's home page

This topic is: not resolved

This topic contains 5 replies, has 2 voices, and was last updated by  TravisPri 9 months, 3 weeks ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #44612

    Kary
    Participant
    Post count: 53

    I have three questions/issues that I don’t understand regarding the Scribble theme. My site is located at http://techiemuse.com. It is in development, so please disregard the dummy text and empty pages. :)

    I obviously made quite a few customizations to the Scribble theme. I am fairly adept at creating themes in WordPress. But this is my first stab at the Genesis framework, so obviously had a few stumbling blocks as I get my feet wet with the process. Also, I have a rudimentary understanding of JQuery, but nothing great.

    A few things to note about the customizations: the anchor link menu that is a feature of the Scribble theme is only being used on the actual homepage of this site. On all other pages, the links at the top take you to the actual pages (except HOME and CONTACT). I am using the Genesis Simple Menus plugin that allows you create custom menus on specific pages. Since it only allows you to change the SECONDARY menu, and its the PRIMARY menu that I needed to change, I had to do some finagling to get that to work. I’m not 100% happy with my solution.

    Issues regarding the homepage’s JQUERY

    (1) On this site from the homepage, the SERVICES link (anchor link) does not work in Firefox. It works in Safari. Does anyone know what might be causing the problem?

    (2) Also, the smooth sliding scroll doesn’t work  when you use the anchor links at the top of the homepage. The TOP links work to go back to the top of the page.

    Question regarding the NAV and SUBNAV

    (3) Is there a way to put the subnav or secondary menu ABOVE the primary menu using Genesis hooks? Or perhaps the better solution would be to create a custom header.php and just change it there? In my solution to solve it temporarily, I just switched the items in the “secondary” menu  and placed them in the “primary” menu. The smaller menu sits on top of the larger one. I would prefer it to sit below the main (larger) menu.

    I tried to fix it with CSS, but that caused other problems down the page. As you can see, I’m dealing with a tight layout where everything needs to sit fairly close to where it is intended. Trying to place subnav and nav menus in reverse order via CSS worked….but not very eloquently. I’m hoping there is an easier solution.

    Thanks in advance.

    • This topic was modified 1 year, 2 months ago by  Kary.
    • This topic was modified 1 year, 2 months ago by  Kary.
    • This topic was modified 1 year, 2 months ago by  Kary.
    • This topic was modified 1 year, 2 months ago by  Kary.
    http://techiemuse.com
    #44749

    Kary
    Participant
    Post count: 53

    I have looked at the site in as many browsers as possible. The “Search” hyperlink works on a PC in IE 8 (don’t have 9), Firefox and Chrome. On a MAC, it works fine in Safari and Chrome. But it doesn’t work on a Mac in Firefox. Would anyone know enough about JQuery to determine why this is happening?

    BTW, clicking on the link in the navigation bar itself doesn’t work. But the correct address is in the address bar (techiemuse.com#services). When I refresh the page it takes me to the correct location. I’ve never seen anything like this in my life.

    Any clues?

    #69813

    TravisPri
    Participant
    Post count: 29

    Hi Kary,

    I know it’s been awhile but I was wondering if you ever found a solution to your problem. I’m trying to use the scribble theme now, and the scrolling is working everywhere except on mobile iPhone – works fine on an iPad which is really bizarre. You would think it would be the same because the operating system is the same.

    Anyway, just wondering if you found the root of your problem and if you wouldn’t mind sharing with me. Your site looks great!

    #69910

    Kary
    Participant
    Post count: 53

    I’m sorry…but I don’t remember what I had to do to fix it. It’s been awhile since I figured it out. However, I don’t think it was anything that would help. Your post caused me to look at my website on the iPad now that I’ve upgraded to the newest version of IOS. The top links no longer work.

    Just for grins, I took a peak at the Scribble Demo that Studio Press has and if its any consolation, their site didn’t work on my iPad either. So it must have something to do with the latest IOS update.

    I suppose someone should let them know. :(

    #69914

    Kary
    Participant
    Post count: 53

    FYI, I submitted a support ticket for the issue. Obviously the code is no longer working with the newest IOS update. It worked previously to me updating.

    #69976

    TravisPri
    Participant
    Post count: 29

    Thanks for getting back to me Kary!

    I also submitted a ticket (yesterday) and haven’t heard yet. I’ll post again when I get more information. For what it’s worth, I’m not even on iOS7 yet but it still wasn’t working.

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.