"read more" link appears always?

Community Forums Forums Design Tips and Tricks "read more" link appears always?

This topic is: not resolved

Tagged: 

This topic contains 9 replies, has 3 voices, and was last updated by  smplcmplxity 1 year ago.

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #65104

    ggsalas
    Participant
    Post count: 8

    Hi,
    I would like that the “read more” link appears only when the content have more than 250 words. In my site appears always.

    Best regards

    http://www.redminka.com
    #65115

    RobG
    Participant
    Post count: 1055

    Go to your Genesis setting and look for the following ( Limit content to, Place your amount here ) characters , You should be good to go.


    To speed up the process please post the link to the website in question.

    We recommend using Firebug to view source codes http://getfirebug.com/

    RobGoss WordPress Developer
    We build WordPress websites for your business or personal goals
    http://www.robgoss.com / Follow me Twitter / https://twitter.com/robgoss

    #65117

    ggsalas
    Participant
    Post count: 8

    Hi @RobG

    I have done this, and in my site appears the “read more” link in all the posts, even if have only one word in the content: http://www.redminka.com/

    #65118

    RobG
    Participant
    Post count: 1055

    Are you trying to remove the Read more link?


    To speed up the process please post the link to the website in question.

    We recommend using Firebug to view source codes http://getfirebug.com/

    RobGoss WordPress Developer
    We build WordPress websites for your business or personal goals
    http://www.robgoss.com / Follow me Twitter / https://twitter.com/robgoss

    #65140

    ggsalas
    Participant
    Post count: 8

    Yes @RobG, I like to remove the “read more” link in the posts that have less than 250 words in the content.

    Best regards

    #66568

    smplcmplxity
    Participant
    Post count: 10

    I would love to know the answer to this question as well. Any information on how to do this?
    I have blog clips on my homepage sidebar but if the blog post is only a sentence and the whole post is shown on the sidebar I don’t need it a “read more” link since there is nothing additional to read. It would be annoying for someone to think there is more to read when there is not.

    So like ggsalas I would like to know how to get rid of the “read more” link when there is less than 100 characters in the post.
    Is there a way to do this?

    Thanks so much!

    #66839

    RobG
    Participant
    Post count: 1055

    I’m failing to understand why the methods I suggeses are not working. I use these same methods on both my blogs. What actually are you doing to add the Readmore function?


    To speed up the process please post the link to the website in question.

    We recommend using Firebug to view source codes http://getfirebug.com/

    RobGoss WordPress Developer
    We build WordPress websites for your business or personal goals
    http://www.robgoss.com / Follow me Twitter / https://twitter.com/robgoss

    #66903

    smplcmplxity
    Participant
    Post count: 10

    Hi RobG!

    I still get a “Read More” link when I have less than 100 characters which is what I set as my limit.

    I have it set up with the Genesis – Featured Posts widget in the sidebar. I put in “Show Content Limit” and “Limit content to 100 characters” & “More Text (if applicable): READ MORE”

    I also tried adding the settings you suggested within the Genesis settings…still no change.

    Take care!
    Christine

    #66919

    ggsalas
    Participant
    Post count: 8

    Hi @smplcmplxity,

    Sorry for the delay. I sole my quesstion with this code:

    add_filter( 'get_the_content_more_link', 'child_read_more_link' );
    function child_read_more_link() {
    $content = apply_filters('the_content',get_the_content());
       if ( strlen($content) < 250 ) {  // Max 250 characters
          return '';
       } else {
    	return '<a class="more-link boton " href="' . get_permalink() . '">Leer más...</a>';
    
       }
    }

    Best regards

    #66924

    smplcmplxity
    Participant
    Post count: 10

    PERFECT!!!!
    Thanks so much @ggsalas

Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.