Second and subsequent archive pages not loading

Community Forums Forums General Discussion Second and subsequent archive pages not loading

This topic is: resolved

This topic contains 9 replies, has 2 voices, and was last updated by  krystyn 1 year, 8 months ago.

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #36145

    krystyn
    Participant
    Post count: 152

    When going to this site, and viewing a months’ archives (for example: http://www.buriedwithchildren.com/2010/05/) The first page loads fine, however, the second page (which clicking the “older posts” link at the bottom) results in a 404 error.

    I deactivated the plugins, so it doesn’t seem to be an issue there. Has anybody seen this before and/or know how to fix it? I looked at the wordpress codex and I found things from years ago and people using custom php for pages, but this is just the default archives page.

     

    Any suggestions would be greatly appreciated.

    #36154

    purplepatriot
    Participant
    Post count: 38

    Hi krystyn,

    Has this the “older posts” functionality worked previously – as far as you know? Or could it have been an issue all along? (Just trying to figure out if it could be linked to some other action.)

    Also, what are the Permalinks settings set for currently?

    I’ve got a couple ideas, but let’s start there.

    Thanks!
    Eric


    Eric @ Coolwater Creative – “Take a leap. Make a splash. Ripple the pond.”
    “Never sacrifice the permanent on the altar of the immediate.” – Give back and help out in the forums.

    #36155

    krystyn
    Participant
    Post count: 152

    Thanks, Eric. As far as I know, it has never worked.

    I’ve also checked to make sure that page counts=10 to see if that helped.

     

    The permalink is set to: http://www.buriedwithchildren.com/sample-post/

    When I change the permalink structure to the default, those pages and subsequent pages work

    http://www.buriedwithchildren.com/?m=201004
    http://www.buriedwithchildren.com/?m=201004&paged=2

     

    So, I’m thinking (based on more checking) is that there is something on the server/hosting side that isn’t correct with mod_rewrite enabled?

    #36157

    purplepatriot
    Participant
    Post count: 38

    If you change Permalinks back to the custom setting, I’m guessing they won’t work again?


    Eric @ Coolwater Creative – “Take a leap. Make a splash. Ripple the pond.”
    “Never sacrifice the permanent on the altar of the immediate.” – Give back and help out in the forums.

    #36158

    krystyn
    Participant
    Post count: 152

    You are correct, changing them back to custom makes them not work again.

     

    Also, this was an issue with a previous theme (thesis) as well.

    #36159

    purplepatriot
    Participant
    Post count: 38

    Can you FTP to the site, pull down a copy of .htaccess (just so you have a copy), then delete .htaccess from the server, go back to Permalinks and set to custom and save again and see if that helps?


    Eric @ Coolwater Creative – “Take a leap. Make a splash. Ripple the pond.”
    “Never sacrifice the permanent on the altar of the immediate.” – Give back and help out in the forums.

    #36181

    krystyn
    Participant
    Post count: 152

    Yes, I can do that….I’m worried about the first line in the file (I’m helping somebody out and I’m not sure why it’s there)?

    RedirectMatch permanent ^/[0-9]{4}/[0-9]{2}/([a-z0-9a-]+) http://buriedwithchildren.com/$1
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

    #36186

    krystyn
    Participant
    Post count: 152

    Hmmm..I deleted that first line and everything works. I wonder if we can figure out why the heck it’s there.

    #36188

    purplepatriot
    Participant
    Post count: 38

    Not sure. But everything works? Yay!!


    Eric @ Coolwater Creative – “Take a leap. Make a splash. Ripple the pond.”
    “Never sacrifice the permanent on the altar of the immediate.” – Give back and help out in the forums.

    #36191

    krystyn
    Participant
    Post count: 152

    I *think* so. I think it’s an old redirect from moving to blogger years ago!

Viewing 10 posts - 1 through 10 (of 10 total)

The topic ‘Second and subsequent archive pages not loading’ is closed to new replies.