Set up Home link on Agency Menu

Community Forums Forums Design Tips and Tricks Set up Home link on Agency Menu

This topic is: not resolved

Tagged: , ,

This topic contains 2 replies, has 2 voices, and was last updated by  trbdesign 2 years, 5 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • #38575



    I want to set my WordPress “Reading” settings to “Static” and use the Genesis Responsive Slider on the front page. I set up a custom link for “Home”, but couldn’t select that in the “Front Page” dropdown box, so I had to choose “About”.  Now the slider shows up both on “Home” and “About”.  I really wanted “About” to function just as a regular page like “Services”, “Portfolio”, etc. Does anyone know how to set “Home” up as a link to I didn’t create a “Home” page in WordPress because I thought it would create problems w/the Genesis menu setup. If someone knows of a tutorial that addresses this, I’d really appreciate it.

    The site is

    Thanks in Advance,

    Toni B




    I couldn’t see the slider on your about page and your home links to your home page so i guess you have resolved these issues?



    Hi Brad,

    Thanks for responding.

    No, I set the the WordPress settings to “Display Latest Posts” even though that’s not what I wanted to do. The slider shows up now on the front page. I want the “About” page to look like the rest of the inside pages.

    What I’d really like is for someone to point me a tutorial/discussion thread that explains how to set up a Genesis theme with a menu that has a “Home” link without having to set it up to show the latest blog posts. I want my blog posts to be on a separate “Blog” link in the menu, and the front page to look like I have it now. It’s my understanding that I can use the genesis responsive slider with static pages or blog posts. Am I just not asking the question correctly? I’ve googled this and searched through the Studiopress forums, but I can’t seem to find an answer.


    Toni B


Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.