Sidebar displaying under content on home page.

Community Forums Forums Design Tips and Tricks Sidebar displaying under content on home page.

This topic is: not resolved

This topic contains 4 replies, has 2 voices, and was last updated by  EricL 1 year, 1 month ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #54053

    EricL
    Participant
    Post count: 4

    Hello Everyone,

    The sidebar displays below at the bottom of my home page and does not align right. It does align correctly to the right of content on single post pages. I might add that this error occurred after I installed a HTML minify widget. Here is my url:

    http://www.thepanamablog.com/

    Any help would be greatly appreciated, I have been trying to fix this for a week now! Also my knowledge of code is little to none.
    I have viewed the site on Firefox, chrome and IE and the sidebar displays incorrectly on all 3 browsers.

    Thanks in Advance,

    Eric

    http://www.thepanamablog.com/
    #54109

    David Chu
    Participant
    Post count: 1361

    Hola,
    #content-sidebar-wrap, which contains both #content and #sidebar, is even narrower than #content. So the whole thing chokes. I don’t see how your single pages can work, either. Here’s where #content-sidebar-wrap is being defined:

    [css]
    .content-sidebar #content-sidebar-wrap, .full-width-content #content-sidebar-wrap, .sidebar-content #content-sidebar-wrap {
    width: 600px;
    }
    [/css]

    #content itself is already 600 wide, AND has 50px of total padding on the sides, adding up to trying to stuff 650 in a 600 container. And only then you add a 300px wide sidebar. The site is throwing up its hands in despair. :-)

    .content-sidebar #content, .sidebar-content #content {
    width: 600px;
    }

    So you’re in for some space recalculation. I’d start with the #content-sidebar-wrap, which has to be much wider to contain all that other stuff. Taking out my trusty calculator, I think about 950px or a touch more should do it. Then you may need to adjust other parts if 950px is too wide for some other contexts.

    Good luck, Dave


    Dave Chu · Custom WordPress Developer – likes collaborating with Designers

    #54157

    EricL
    Participant
    Post count: 4

    Thank You Dave,

    My home page is fixed! However, now my single page the sidebar drops below the post content but is still right aligned. I can tell by adjusting this element in firebug :
    .content-sidebar #content-sidebar-wrap, .full-width-content #content-sidebar-wrap, .sidebar-content #content-sidebar-wrap {
    width: 950px;
    That when the width is set to 950px, my home page works and not the single post. When its set to 600px, The single post works but not the home page.

    Thanks for the help,

    Eric

    #54196

    EricL
    Participant
    Post count: 4

    Using Firebug I believe I have found what is causing this error:
    The code under body.home displays the wrap as such
    <div class=”wrap”>
    <div id=”content-sidebar-wrap”>
    <div id=”content” class=”hfeed”>
    <div id=”sidebar” class=”sidebar widget-area”>
    The code under body.single is coded like this:

    <div class=”wrap”>
    <div id=”content-sidebar-wrap”>
    <div id=”content” class=”hfeed”>
    </div>
    <div id=”sidebar” class=”sidebar widget-area”>

    The <div id=”sidebar” class=”sidebar widget-area”> is outside of the <div id=”content-sidebar-wrap”> on the single post page.

    How can I adjust this, if it is the problem?

    Thank You,

    Eric

    #54284

    EricL
    Participant
    Post count: 4

    I would like to let forum members know that my problem has been solved. Thanks to Andrea from Technical Support, she had me disable all my plugins and add them back one by one(which I now know is what I should have done in the first place, but i was in a panic!). The cause of the problem was a plugin called SEO autolinker. Thank you to David Chu and Andrea, my blog is working Correctly again,

    Eric

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.