Simple Hooks 2.0.0 Issue Unhooking Title and Meta Info

Community Forums Forums Design Tips and Tricks Simple Hooks 2.0.0 Issue Unhooking Title and Meta Info

This topic is: not resolved

This topic contains 2 replies, has 2 voices, and was last updated by  flailiak 7 months, 4 weeks ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #55109

    flailiak
    Participant
    Post count: 2

    I just updated to Genesis 2.0, and upgrade my News theme to HTML5, and I also updated to the new Simple Hooks 2.0.0. plugin that came out like an hour ago.

    One of the hooks I used the plugin for previously was genesis_before_post_content, which is now the genesis_entry_header hook.


    <?php if ( is_page() || is_single() ) {?>
    <div style="float:left;margin: 0px 10px 5px 0px;">

    "adsense script here"

    </div>
    <?php }?>

    This makes my adsense ad appear at the top left corner on pages like here:

    http://www.maximizingmoney.com/bank-bonuses-banking-deals-and-bank-promotions/

    And on posts like here:

    http://www.maximizingmoney.com/credit-cards-offer-deals/barclaycard-arrival-credit-cards-offer-up-to-20000-bonus-miles-for-200-statement-credit/

    However, prior to the plugin update, I was able to Unhook genesis_post_info() function from this hook, which removed the posted date and comments meta info from above the post content, where you can see it in the above link.

    However, with the new plugin version, this unhook function is no longer available, so the date/posted by/comments info still appears both above the content on posts and on my main home page.

    http://www.maximizingmoney.com

    I’ve like to remove this info, but am unsure how.

    If anybody has any suggestions as to how to do it with the new Simple Hooks plugin or another way, please help me.

    What’s really weird is that I updated Simple Hooks to 2.0.0. in 2 different blogs, and my other blog still has the Post/Page Hooks section and functions fine, while this blog now has the new Entry Hooks section and is having this problem. Not sure how that’s possible to have 2 version of the new plugin after updating both.

    I know this is a brand-new issue, but really would appreciate any help.

    http://www.maximizingmoney.com
    #58784

    Kurt
    Participant
    Post count: 8

    I’m having this same issues.

    I checked out your site and it looks like you were able to remove the date/posted-by meta information.

    What was the fix?

    Thanks.

    #59083

    flailiak
    Participant
    Post count: 2

    Hi Kurt,

    I added this code below to my theme’s functions.php file:

    //* Remove the entry meta in the entry header (requires HTML5 theme support)
    remove_action( 'genesis_entry_header', 'genesis_post_info', 12 );

    I found the answer over at this link:

    http://my.studiopress.com/snippets/entry-header/

    Sorry I didn’t update this earlier with the resolution, but my original post was under review, and I didn’t even realize it went live.

    Anyway, hope this helps.

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.