Single post nav stopped working on Minimum

Community Forums Forums Design Tips and Tricks Single post nav stopped working on Minimum

This topic is: not resolved

This topic contains 2 replies, has 2 voices, and was last updated by  nutsandbolts 1 year, 2 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #10680

    nutsandbolts
    Moderator
    Post count: 2615

    Hi guys,

    So I switched from Focus to Minimum and just noticed that my single post navigation no longer displays. This is the code in my functions.php:

    function custom_post_navigation()
    {
    ?>
    <div class=”prev_next”>
    <div class=”nav_left”>
    <span class=”prev”>Previous Post</span> <?php previous_post_link(‘%link’, ‘%title’); ?>
    </div class=”nav_right”>
    <div>
    <span class=”next”>Next Post</span> <?php next_post_link(‘%link’, ‘%title’); ?>
    </div>
    </div>
    <?php
    }

    add_action(‘genesis_after_comments’, ‘custom_post_navigation’);

    And here’s the CSS I used:

    .prev_next
    {
    overflow: auto;
    margin: 10px 0;
    padding: 5px 0;
    }
    .prev_next span.next
    {
    border-bottom: 1px solid #E6E6E6;
    display: block;
    margin-bottom: 5px;
    }
    .prev_next span.prev
    {
    border-bottom: 1px solid #E6E6E6;
    display: block;
    margin-bottom: 5px;
    }
    .prev_next a
    {
    text-decoration: none;
    }
    .prev_next a:hover
    {
    text-decoration: underline;
    }
    .nav_left
    {
    width: 50%;
    float: left;
    }
    .nav_right
    {
    width: 50%;
    float: right;
    text-align: right;
    }

    This has always worked perfectly on any child theme I’ve used, so I’m a little lost as to why it’s not showing the navigation on Minimum. Would appreciate any thoughts. The URL is http://www.sooverthis.com


    Andrea Whitmer, Owner, Nuts and Bolts Media
    I do Genesis tutorials, design and development, and other fun stuff • Find me on Twitter and Google+

    #15156

    SoZo
    Moderator
    Post count: 1573

    You could use this plugin


    John “Nicolas Flamel” Wright | SoZo’s design| John Wright Photography

    #15207

    nutsandbolts
    Moderator
    Post count: 2615

    Yeah, I tried that as a last resort. It isn’t working either. It’s the weirdest thing I’ve ever seen. For now I’ve just given up having single post navigation until I can figure out what’s causing the problem.


    Andrea Whitmer, Owner, Nuts and Bolts Media
    I do Genesis tutorials, design and development, and other fun stuff • Find me on Twitter and Google+

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.