Streamline theme: pictures auto creates itself when adding a photo

Community Forums Forums General Discussion Streamline theme: pictures auto creates itself when adding a photo

This topic is: not resolved

This topic contains 5 replies, has 4 voices, and was last updated by  dougweiss 1 year, 7 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #3916

    jstar
    Participant

    Hey,

     

    not sure if this is a more advanced thing…..

    but whenever I add a picture to a post, the theme automatically generates a picture above the post, in its own separate section. I thought it was a thumbnail thing and disabled thumbnails. But that;s not the case.

    I only need 1 photo and this is annoying. I have a feeling it’s in the css or something? I have a feeling the theme is set up to do this automatically?

    Any idea on how I can fix?

    Thank you.

    • This topic was modified 1 year, 7 months ago by  jstar.
    • This topic was modified 1 year, 7 months ago by  jstar.
    #3920

    anitac
    Participant
    Post count: 6991

    You might want to put in a Support Ticket on that one.


    Let me help you customize your theme, responsive header, Buddypress, Agentpress or technical issue!
    Visit me here: Cre8tiveDiva.com | Tweet Me! | Plus Me!
    When asking for help, please provide a link or screen shot showing your problem!

    #3924

    Susan
    Moderator
    Post count: 7984

    I agree with Anita – submit a support ticket…

    But, in the meantime, are you checking the “featured” image box, and inserting the image into a post? I believe if you do that, it will generate a duplicate image.

    Also, you should go ahead and include a link to your site when you ask a question on the board here – it makes it easier to troubleshoot if we can see your site. :)


    Susan @ Graphically Designing I’d love to customize your website! I tweet!
    I’ve taken up the challenge! – help me answer some of the unanswered posts

    #3927

    jstar
    Participant

    thanks guys.

    I will send a support ticket.

    and just in case anyone was curisous, i did not have “featured” image box checked.

     

    Thanks!

    #3928

    Susan
    Moderator
    Post count: 7984

    I know you said you disabled thumbnails, but check this, too:

    Go to Genesis -> Settings -> Content Archives and uncheck the box to show thumbnails on archive page.


    Susan @ Graphically Designing I’d love to customize your website! I tweet!
    I’ve taken up the challenge! – help me answer some of the unanswered posts

    #4399

    dougweiss
    Participant

    To remove the large featured image above the post, open up the functions.php in the child theme folder.

    Find this section of code and remove it.

    [PHP]

    /** Add post image above post title */
    add_action( ‘genesis_before_post’, ‘streamline_post_image’ );
    function streamline_post_image() {

    if ( is_page() ) return;

    if ( $image = genesis_get_image( ‘format=url&size=post-image’ ) ) {
    printf( ‘‘, get_permalink(), $image, the_title_attribute( ‘echo=0′ ) );
    }

    }[/PHP]

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.