Subscription to newsletter not working properly

Community Forums Forums Design Tips and Tricks Subscription to newsletter not working properly

This topic is: resolved

This topic contains 19 replies, has 2 voices, and was last updated by  Cesc Vilanova 1 year, 8 months ago.

Viewing 15 posts - 1 through 15 (of 20 total)
  • Author
    Posts
  • #2471

    Cesc Vilanova
    Participant
    Post count: 18

    Hi,

    I was trying to implement this in my site…

    http://www.briangardner.com/email-newsletter-signup-box/

    but even though I followed the tutorial step by step, I couldn’t.

    It only appeared a header and a text box at the end of each post, but not the “Subscribe” button nor the graphic assets I did upload.

    I’ve disabled the widget until it looks and works ok.

    Here you can see my Minimum 2.0. based blog:
    http://cescvilanova.com/lo-que-haga-la-competencia-pero-6-meses-despues/

    ¿Can you give me some clues to make it work?

    Thanks a lot,

    Cesc.

    #2969

    Cesc Vilanova
    Participant
    Post count: 18

    Hi again,

    I couldn’t make it work yet. Has someone had a similar problem?

    Thanks again,

    Cesc.

    #5000

    Kraft
    Participant
    Post count: 87

    Hi Cesc,

    Can you reactive the widget so I can have a look at what it’s doing (and not doing)?

    Cheers,

    Kraft


    Brandon Kraft
    Volunteer
    Blog | Twitter
    Genesis eNews Extended Support

    #5001

    Kraft
    Participant
    Post count: 87

    One quick thing I noticed. You added the code from Step 2 to style.css– that should be in functions.php. I can’t see what’s in your functions.php, so if you already added it there–great! Do remove it from style.css though. :-)


    Brandon Kraft
    Volunteer
    Blog | Twitter
    Genesis eNews Extended Support

    #5066

    Cesc Vilanova
    Participant
    Post count: 18

    Thanks Kraft!

    I’ve just:

    1. Removed the unnecessary code from the style.css :p

    2. Confirmed that the code required for the functions.php is in the file.

    3. Reactivated the widget again.

    The result is the same of the first time I tried to install it.

    You can see how it looks here: http://cescvilanova.com/lo-que-haga-la-competencia-pero-6-meses-despues/

    • This reply was modified 1 year, 10 months ago by  Cesc Vilanova.
    • This reply was modified 1 year, 10 months ago by  Cesc Vilanova.
    #5073

    Kraft
    Participant
    Post count: 87

    Hmm. I’m not seeing the code from Step 4 in your style.css. I applied it on my development end and it looks right. Can you verify that styling is in your style. css (and possibly empty your cache if you’re using a caching plugin/host provider).

    I’d also change the .enews-widget (the first section of the style in step 4) to say margin: 25px 10% or something similar to keep the widget from bumping too close to the meta above it.


    Brandon Kraft
    Volunteer
    Blog | Twitter
    Genesis eNews Extended Support

    #5076

    Cesc Vilanova
    Participant
    Post count: 18

    Hi!

    I just added the code from step 4 (my mistake).

    I’ve also adjusted the parameter of the margin and emptied the cache, but it looks the same. I’m probably missing something simple but I don’t know what :)

    Thanks.

     

    #5082

    Kraft
    Participant
    Post count: 87

    Found it. You pasted the Step 4 code just a line too early. Check out the code above what you pasted — that’s for when the screen is max-width of 300px.

    You’ll want to add a } just above what you pasted and remove the second } at the end of the file. That’ll close the media query and get the enews styles active.


    Brandon Kraft
    Volunteer
    Blog | Twitter
    Genesis eNews Extended Support

    #5083

    Cesc Vilanova
    Participant
    Post count: 18

    Corrected!

    It now looks ok. The only think missing is the button to subscribe. I’ve checked the settings of the widget and everything seems ok.

    #5087

    Kraft
    Participant
    Post count: 87

    The minimum theme purposely removes it, but you can get it back by removing around line 1236 of style.css.

    Remove .enews #subbutton, .searchsubmit {
    display: none;
    }

    Update: Rather, just remove the .enews #subbutton, part of that if you want to keep the search submit button hidden too.


    Brandon Kraft
    Volunteer
    Blog | Twitter
    Genesis eNews Extended Support

    • This reply was modified 1 year, 10 months ago by  Kraft. Reason: didn't want to screw up his search submit
    • This reply was modified 1 year, 10 months ago by  Kraft. Reason: didn't want to screw up his search submit
    #5092

    Cesc Vilanova
    Participant
    Post count: 18

    Ok. I would only need to adjust the color of the button and the space between the button and the text box, since they’re too close from each other.

    Which of these should I adjust?
    .enews #subbox,
    .s {
    -moz-box-shadow: 0 0 5px #ccc inset;
    -webkit-box-shadow: 0 0 5px #ccc inset;
    background-color: #fff;
    border: 1px solid #ccc;
    box-shadow: 0 0 5px #ccc inset;
    box-sizing: border-box;
    color: #999;
    font-family: ‘Open Sans’, sans-serif;
    font-size: 12px;
    padding: 15px;
    text-transform: uppercase;
    width: 90%;
    }
    #nav .searchform {
    margin: 3px 0 0;
    }
    .searchsubmit {
    display: none;
    }
    .enews p {
    margin: 0 0 10px;
    }

    #5116

    Kraft
    Participant
    Post count: 87

    If you use Firefox, you can install the Firebug add-on or with Chrome, you can right-click on something on page and click on “Inspect Element”. I learned a lot of CSS by playing inside of Chrome’s inspector.

    Checking out the submit button, the styling code for that is at line 1797 of style.css (search for .enews #subbutton), the background-color is the grey currently. The “color” is the text color.

    For the spacing, I’d add some margin to the right of the e-mail box. To the .enews #subbox settings, you can add: margin-right: 10px; (10 can be adjusted to whatever you want).


    Brandon Kraft
    Volunteer
    Blog | Twitter
    Genesis eNews Extended Support

    #5118

    Cesc Vilanova
    Participant
    Post count: 18

    Thanks for the tip about the inspector. I was using a similar option in Safari, but the one in Chrome is far better.

    About the spacing, sorry, but I’m not getting it. This is how I have upated the css but nothing changes:

    .enews #subbox,
    .s {
    -moz-box-shadow: 0 0 5px #ccc inset;
    -webkit-box-shadow: 0 0 5px #ccc inset;
    background-color: #fff;
    border: 1px solid #ccc;
    box-shadow: 0 0 5px #ccc inset;
    box-sizing: border-box;
    color: #534E4E;
    font-family: ‘Open Sans’, sans-serif;
    font-size: 12px;
    padding: 15px;
    text-transform: none;
    width: 90%;
    margin-right: 10px
    }

    #nav .searchform {
    margin: 10px 0 0;
    }

    .searchsubmit {
    display: none;
    }

    .enews p {
    margin: 0 0 10px;
    }

     

    #5131

    Kraft
    Participant
    Post count: 87

    Looks like you’re missing the ending semicolon from the margin-right: 10px; line. Honestly not sure if that’s enough to throw it off, but good chance it is!


    Brandon Kraft
    Volunteer
    Blog | Twitter
    Genesis eNews Extended Support

    #5188

    Cesc Vilanova
    Participant
    Post count: 18

    I’ve just added the semicolon but doesn’t seem to work yet. This is the code of that part of the css right now:
    .enews #subbox,
    .s {
    -moz-box-shadow: 0 0 5px #ccc inset;
    -webkit-box-shadow: 0 0 5px #ccc inset;
    background-color: #fff;
    border: 1px solid #ccc;
    box-shadow: 0 0 5px #ccc inset;
    box-sizing: border-box;
    color: #534E4E;
    font-family: ‘Open Sans’, sans-serif;
    font-size: 12px;
    padding: 15px;
    text-transform: none;
    width: 90%;
    margin-right: 10px;
    }
    #nav .searchform {
    margin: 10px 0 0;
    }
    .searchsubmit {
    display: none;
    }
    .enews p {
    margin: 0 0 10px;
    }

Viewing 15 posts - 1 through 15 (of 20 total)

You must be logged in to reply to this topic.