superfish menu dropdown not working with recent posts slider

Community Forums Forums Design Tips and Tricks superfish menu dropdown not working with recent posts slider

This topic is: not resolved

This topic contains 5 replies, has 2 voices, and was last updated by  senordeer 10 months, 4 weeks ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #59967

    senordeer
    Participant
    Post count: 22

    Blog address: http://thedecorista.com
    Theme: Genesis sample child

    I have added a recent posts slider using Simple Hooks below the nav bar using the before-content-sidebar hook. It’s all good except on the pages that the slider is enabled, the More menu link is not dropping down. It works fine on the pages where I have the posts slider hidden. I tried adding some z-index positioning, but nothing seems to help. It is fine if the sub pages drop down over the posts slider, I just want to make sure they drop down. Many thanks in advance!

    http://thedecorista.com
    #60003

    Sridhar Katakam
    Participant
    Post count: 923

    It works fine on the pages where I have the posts slider hidden.

    Can you give the URL of any one such page? I checked a few pages of your site and More menu item’s sub menu does not drop down any where.


    #60028

    senordeer
    Participant
    Post count: 22

    Oh, interesting, now it isn’t working on any of the pages. Any suggestions?

    #60033

    Sridhar Katakam
    Participant
    Post count: 923

    While the following will not fix the issue, it is a pre-requisite that you might want to take of.

    There are a lot of errors in the CSS in child theme’s style.css as can be seen at http://jigsaw.w3.org/css-validator/validator?profile=css21&warning=0&uri=http%3A%2F%2Fthedecorista.com%2F

    I have corrected them and you can find the fixed code at http://pastie.org/private/ahduvtadqdrmgru9znmrg


    #60042

    senordeer
    Participant
    Post count: 22

    Oh wow, that is great, thank you, I updated it. But you are correct, it still did not fix the dropdown menu problem, and oddly enough, it was working fine on my development site:

    http://beta.thedecorista.com

    But I can’t seem to replicate the dropdown performance on the new site?

    #60048

    senordeer
    Participant
    Post count: 22

    Oh! I think I see what part of the problem may be, now when you try to access the submenu when coming from a static page, eg. http://thedecorista.com/services, it is accessible, it looks like the padding increases around the little subindicator icon. But only on static pages.

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.