Two page speed + retina screen question

Community Forums Forums General Discussion Two page speed + retina screen question

This topic is: not resolved

This topic contains 5 replies, has 3 voices, and was last updated by  sp65 1 year, 2 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #15531

    daveerin
    Participant
    Post count: 46

    I have recently checked my site on pingdom to see how I can optimise my site to get minimum loading time for readers.

    It seems the major problem i have is the ‘wait time for the first byte’. It just sits and wait for 1.53 seconds before it even loads wordpress or the theme. My hosting service says there is nothing they can do. Does anybody have experience with this? How can I reduce the waiting time? Other than get better hosting.. which I may do anyway.

    Also one last question on page speed. It seems that resizing images in html is a no no.. so I have edited all the pictures before uploading them so they are already the correct size.. and then optimised them so they are small files… but on my home page their are little images to showcase the featured posts, these are resized. Does everybody upload their images twice? One size for in the posts and one for the featured image that is smaller for the homepage or sidebar perhaps?

    Ive just been reading about the retina’s screen also and how small jpg files look rubbish on them as they size everything up by x2. So it seems with page speed and retina screens, it is very difficult to optimise for both. There is a plugin called WP-Retina I think its called which saves a very large size image and only delivers that to retina screens but I can image this taking up lots of bandwith and the rest of it. Interested to hear how people are preparing their sites for some traffic viewing through super big screens and some people still struggling with low internet connections..


    We are Dave & Erin. Full time travellers and designers. Follow us on Google + or follow our journey on NomadSpirit.net. We also collect Resources for Genesis

    #15532

    daveerin
    Participant
    Post count: 46

    ps my site is nomadspirit.net if it helps with answering. thanks!


    We are Dave & Erin. Full time travellers and designers. Follow us on Google + or follow our journey on NomadSpirit.net. We also collect Resources for Genesis

    #15533

    daveerin
    Participant
    Post count: 46

    PS here is a link to a screen shot of Pingdom to show you what i mean. the yellow indicates waiting time. So, as you can see in the image, half of the whole loading time is just waiting time before even starting to download anything..

    http://nomadspirit.net/wp-content/uploads/2013/01/Screen-Shot-2013-01-28-at-4.01.46-PM.png

    I dont seem to find any info apart from forums telling people to contact their hosting, which I did. But they said it is not them.

    Again, thanks. Any help pointing me in the right direction would be much appreciated!


    We are Dave & Erin. Full time travellers and designers. Follow us on Google + or follow our journey on NomadSpirit.net. We also collect Resources for Genesis

    #18881

    sp65
    Participant
    Post count: 17

    Hi,  did you ever get an answer to this ?   I’m starting to review my sites performance. GooglePageSpeed has always given it a high score, but when I use webpagetest.org the performance is lacking;

     


    First Byte Time (back-end processing): 37/100
    786 ms First Byte Time
    162 ms Target First Byte Time
    The problem seems to be around a 301 redirect to my theme ?   Or maybe I’m interpreting it incorrectly.


    #18891

    Vajrasar Goswami
    Participant
    Post count: 156

    on the part of images – wordpress itself makes copy of your image as thumbnail to show in posts when they had to show a small image, you do not need to insert/upload multiple instance of a same image.

    Here is the literature I found about ‘time to first byte’, do read -

    http://blog.cloudflare.com/ttfb-time-to-first-byte-considered-meaningles


    Twitter – Vajrasar

    #18902

    sp65
    Participant
    Post count: 17

    Thanks for that link.  I think this whole pagespeed thing is a bit of a minefield,  I am lucky enough to have a quick switch on of cloudflare via my host,  and it does appear to load quicker now, but not every time.

     


Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.