Username (author) in URL links

Community Forums Forums Design Tips and Tricks Username (author) in URL links

This topic is: resolved

This topic contains 8 replies, has 2 voices, and was last updated by  joycegrace 1 year, 8 months ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #25539

    Rita
    Participant
    Post count: 89

    I was looking at my archives by author today and just realized usernames appear in the URL link when you click to see all the posts associated to an author. Is there anyway to change this???? I thought my nickname would appear there after I selected my nickname to appears.  I’ve had a lot of issues with hackers the last several months and the bots continue to hit my site, but now I’m concerned because anyone can now see my username and just try to hack using a bot to figure out my password even though my password is pretty nutty.

    #25604

    joycegrace
    Participant
    Post count: 58

    If you are trying to get a different name to appear, you need to edit this in “users.” Enter your nickname, then from the dropdown you can select what you want to show publicly, and save.

    If you want to remove the author name from your posts, install Genesis Simple Edits plugin, it will allow you to do this easily.

    If you want to disable author based archives (probably a good idea from an SEO standpoint) install and activate WordPress SEO by Yoast plugin and click on the setting that allows you to do that.

    Hope this helps.


    Find me at Joyce Grace (http://www.joycegrace.ca) and Clicks Online Marketing (clicksonlinemarketing.com).

    #34740

    Rita
    Participant
    Post count: 89

    Hi Joyce.

    I have nicknames for users, but the nicknames don’t show up in the URL link when you go to an author’s archive. The actual username does. For instance… http://www.domainname.com/author/yipp786skhu as opposed to /author/rita

     

    #34893

    joycegrace
    Participant
    Post count: 58

    Hi YippyMomma,

     

    If I were you I would install WordPress SEO by Yoast and “disable” the author archives. They are not that useful for SEO anyway, and can actually be harmful since they are full of duplicate content.

    If you can link to your site that might help too.

    If you are having problems with hackers, it could be that your passwords are not strong enough (very common problem, probably a bigger problem than your usernames). You should be coming up with passwords similar to what would be generated by strongpasswordgenerator.com. I also use this site to generate usernames, for extra precaution.

    You also should get rid of the author ID “1” – if you install Better WP Security, it can do this for you easily (but be careful not to use settings in that plugin you are not familiar with)

    This plugin can also rename you database table prefixes and hide your backend login urls, so they are no longer at /wp-admin or /wp-login, and so on.

    It also does other things, like it can show a random version number to all logged in users, and other security precautions.

    Just use the plugin with caution. If you don’t know how to “undo” some things that might affect your site, you would have a hard time. Always do a backup before you install any plugin. In fact you should have VaultPress or BackupBuddy installed and running at all times in any case.


    Find me at Joyce Grace (http://www.joycegrace.ca) and Clicks Online Marketing (clicksonlinemarketing.com).

    #34915

    Rita
    Participant
    Post count: 89

    Thanks for your suggestions. I had the hacking issues nov to jan with a different host. I have implemented a lot of security items since then including better wp security (last month) and other things you suggested above. My passwords and usernames are all extremely crazy looking now. I can’t even remember them. I guess I’ll just go ahead with disabling the author archives. That’s the only thing I haven’t done. Thanks.

    #34917

    Rita
    Participant
    Post count: 89

    I even installed WordPress manually just so I could create my own database names, usernames and such. thanks for taking the time to answer my thread.

    #34927

    joycegrace
    Participant
    Post count: 58

    Sorry I couldn’t offer more of a resource. I think you’d have to get into some pretty techy stuff to change the URLs otherwise.

    Be careful with Better WP Security for a while it was causing A LOT of errors in my Webmaster Tools and Google could not crawl my site. I found out it has to do with the “intrusion detection” settings. Just a tip, not sure if it will happen to you as well.


    Find me at Joyce Grace (http://www.joycegrace.ca) and Clicks Online Marketing (clicksonlinemarketing.com).

    #34941

    Rita
    Participant
    Post count: 89

    Thanks for the tip on the intrusion. I was actually having issues with my SSL and figured out the forced SSL option in better work was causing the conflict. Had to turn that piece off so the SSL could work properly and push checkout into https mode. Thanks for thoroughly help Joyce.

    #35090

    joycegrace
    Participant
    Post count: 58

    No problem!


    Find me at Joyce Grace (http://www.joycegrace.ca) and Clicks Online Marketing (clicksonlinemarketing.com).

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.