Using Google Web Fonts in a Multisite Environment

Community Forums Forums Design Tips and Tricks Using Google Web Fonts in a Multisite Environment

This topic is: not resolved

This topic contains 3 replies, has 3 voices, and was last updated by  braddalton 1 year ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #56079

    IOStreamCTO
    Participant
    Post count: 3

    Situation:

    • Running WordPress 3.6 in a network (multisite) configuration.
    • Genesis 2.0.0 installed and network enabled.
    • Genesis Sample Child Theme installed and network enabled.

    Question Regarding Google Fonts Integration:
    I have read Mr. Gardner’s integration instructions at “http://www.studiopress.com/tips/google-web-fonts.htm” (How to Use Google Web Fonts With Your Genesis-Powered Website). However, if I follow this method, would not every site that uses the same child theme display whichever Google font was selected using the @import method? For example, lets say I had four (4) sites all using the Genesis Sample Child Theme. I could certainly select a heading and body font for each site and follow the @import function with the ‘family=’ commands for eight fonts and then define the required font for each individual element on each site using CSS , but this would cause a significant load time impact on the 4 sites.

    Not being a web developer, it would seem to be safest to create and call an external stylesheet (using the @import) method for each site when working in a multisite environment – but I am probably totally wrong and am not sure how to do this in a multisite configuration even if this were the correct method. I know many talented developers and StudioPress product experts frequent this forum. If any of you have the time to type a “Google Fonts for Dummies” tutorial as it relates to a multisite environment in response to this post, it would be GREATLY appreciated. I am sure I am not the only person in this situation, so if you decide to post a tutorial on your site and link me to it, I promise to post a glowing review in the comments section!

    Thank you in advance for any assistance, I truly appreciate your time and attention to this issue!

    • This topic was modified 1 year, 3 months ago by  IOStreamCTO. Reason: Embedded link did not display
    • This topic was modified 1 year, 3 months ago by  IOStreamCTO. Reason: Embedded link did not display
    http://n/a
    #73596

    Susan
    Moderator
    Post count: 9359

    I see you posted this a while back, so I hope you got your issue resolved. If not, come back and check in, and I’ll escalate it for you…


    Susan @ Graphically Designing I offer theme customizations I tweet!
    I’ve taken up the challenge! – help me answer some of the unanswered posts

    #73942

    IOStreamCTO
    Participant
    Post count: 3

    Thanks, Susan! No, I have not discovered a satisfactory resolution to this issue so escalation to someone who may have the advanced knowledge to address this issue would be greatly appreciated. My original post should be modified to reflect that my multisite configuration is running the very latest versions of WordPress, Genesis, and StudioPress themes.

    Again, thank you in advance for any assistance. I truly appreciate your time and attention to this issue!

    #73948

    braddalton
    Participant
    Post count: 10553

    You could add the conditional tag for each sub site with i.d after the function in this code and use it in a plugin:


Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.